summaryrefslogtreecommitdiff
path: root/gcc-defaults
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2012-10-24 14:48:04 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2012-10-24 14:48:04 +0400
commit98cb3b26f4043c9a83029c21855ff61b7601e611 (patch)
treee0e08eb9e6a168c65444dfc9751a522cb08b0ab3 /gcc-defaults
downloadcibs-pkgs-98cb3b26f4043c9a83029c21855ff61b7601e611.tar.gz
Initial commit from cibs/examples
Diffstat (limited to 'gcc-defaults')
-rw-r--r--gcc-defaults/Makefile5
-rw-r--r--gcc-defaults/cpp.p5m32
-rw-r--r--gcc-defaults/g++.p5m32
-rw-r--r--gcc-defaults/gcc.p5m32
-rw-r--r--gcc-defaults/gfortran.p5m32
5 files changed, 133 insertions, 0 deletions
diff --git a/gcc-defaults/Makefile b/gcc-defaults/Makefile
new file mode 100644
index 0000000..9e87543
--- /dev/null
+++ b/gcc-defaults/Makefile
@@ -0,0 +1,5 @@
+include /usr/share/cibs/rules/ips.mk
+
+default-version := 4.4
+version := $(default-version)
+
diff --git a/gcc-defaults/cpp.p5m b/gcc-defaults/cpp.p5m
new file mode 100644
index 0000000..96df610
--- /dev/null
+++ b/gcc-defaults/cpp.p5m
@@ -0,0 +1,32 @@
+#
+# CDDL HEADER START
+#
+# The contents of this file are subject to the terms of the
+# Common Development and Distribution License (the "License").
+# You may not use this file except in compliance with the License.
+#
+# You can obtain a copy of the license
+# at http://www.opensource.org/licenses/CDDL-1.0
+# See the License for the specific language governing permissions
+# and limitations under the License.
+#
+# When distributing Covered Code, include this CDDL HEADER in each file.
+# If applicable, add the following below this CDDL HEADER, with the
+# fields enclosed by brackets "[]" replaced with your own identifying
+# information: Portions Copyright [yyyy] [name of copyright owner]
+#
+# CDDL HEADER END
+#
+#
+# Copyright (C) 2012, Nexenta Systems, Inc. All rights reserved.
+#
+
+
+set name=pkg.fmri value=pkg:/developer/gcc/cpp@$(ips-version)
+set name=pkg.summary value="GNU C preprocessor, default version"
+
+depend fmri=pkg:/developer/gcc/cpp-$(default-version) type=require
+
+link path=usr/bin/cpp target=cpp-$(default-version)
+link path=usr/share/man/man1/cpp.1 target=cpp-$(default-version).1
+
diff --git a/gcc-defaults/g++.p5m b/gcc-defaults/g++.p5m
new file mode 100644
index 0000000..255a0c3
--- /dev/null
+++ b/gcc-defaults/g++.p5m
@@ -0,0 +1,32 @@
+#
+# CDDL HEADER START
+#
+# The contents of this file are subject to the terms of the
+# Common Development and Distribution License (the "License").
+# You may not use this file except in compliance with the License.
+#
+# You can obtain a copy of the license
+# at http://www.opensource.org/licenses/CDDL-1.0
+# See the License for the specific language governing permissions
+# and limitations under the License.
+#
+# When distributing Covered Code, include this CDDL HEADER in each file.
+# If applicable, add the following below this CDDL HEADER, with the
+# fields enclosed by brackets "[]" replaced with your own identifying
+# information: Portions Copyright [yyyy] [name of copyright owner]
+#
+# CDDL HEADER END
+#
+#
+# Copyright (C) 2012, Nexenta Systems, Inc. All rights reserved.
+#
+
+
+set name=pkg.fmri value=pkg:/developer/gcc/g++@$(ips-version)
+set name=pkg.summary value="GNU C++ compiler, default version"
+
+depend fmri=pkg:/developer/gcc/g++-$(default-version) type=require
+
+link path=usr/bin/g++ target=g++-$(default-version)
+link path=usr/share/man/man1/g++.1 target=g++-$(default-version).1
+
diff --git a/gcc-defaults/gcc.p5m b/gcc-defaults/gcc.p5m
new file mode 100644
index 0000000..6e860eb
--- /dev/null
+++ b/gcc-defaults/gcc.p5m
@@ -0,0 +1,32 @@
+#
+# CDDL HEADER START
+#
+# The contents of this file are subject to the terms of the
+# Common Development and Distribution License (the "License").
+# You may not use this file except in compliance with the License.
+#
+# You can obtain a copy of the license
+# at http://www.opensource.org/licenses/CDDL-1.0
+# See the License for the specific language governing permissions
+# and limitations under the License.
+#
+# When distributing Covered Code, include this CDDL HEADER in each file.
+# If applicable, add the following below this CDDL HEADER, with the
+# fields enclosed by brackets "[]" replaced with your own identifying
+# information: Portions Copyright [yyyy] [name of copyright owner]
+#
+# CDDL HEADER END
+#
+#
+# Copyright (C) 2012, Nexenta Systems, Inc. All rights reserved.
+#
+
+
+set name=pkg.fmri value=pkg:/developer/gcc/gcc@$(ips-version)
+set name=pkg.summary value="GNU C compiler, default version"
+
+depend fmri=pkg:/developer/gcc/gcc-$(default-version) type=require
+
+link path=usr/bin/gcc target=gcc-$(default-version)
+link path=usr/share/man/man1/gcc.1 target=gcc-$(default-version).1
+
diff --git a/gcc-defaults/gfortran.p5m b/gcc-defaults/gfortran.p5m
new file mode 100644
index 0000000..a690ec2
--- /dev/null
+++ b/gcc-defaults/gfortran.p5m
@@ -0,0 +1,32 @@
+#
+# CDDL HEADER START
+#
+# The contents of this file are subject to the terms of the
+# Common Development and Distribution License (the "License").
+# You may not use this file except in compliance with the License.
+#
+# You can obtain a copy of the license
+# at http://www.opensource.org/licenses/CDDL-1.0
+# See the License for the specific language governing permissions
+# and limitations under the License.
+#
+# When distributing Covered Code, include this CDDL HEADER in each file.
+# If applicable, add the following below this CDDL HEADER, with the
+# fields enclosed by brackets "[]" replaced with your own identifying
+# information: Portions Copyright [yyyy] [name of copyright owner]
+#
+# CDDL HEADER END
+#
+#
+# Copyright (C) 2012, Nexenta Systems, Inc. All rights reserved.
+#
+
+
+set name=pkg.fmri value=pkg:/developer/gfortran/gfortran@$(ips-version)
+set name=pkg.summary value="GNU Frotran 95 compiler, default version"
+
+depend fmri=pkg:/developer/gcc/gfortran-$(default-version) type=require
+
+link path=usr/bin/gfortran target=gfortran-$(default-version)
+link path=usr/share/man/man1/gfortran.1 target=gfortran-$(default-version).1
+