summaryrefslogtreecommitdiff
path: root/c-ares
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2012-10-24 14:48:04 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2012-10-24 14:48:04 +0400
commit98cb3b26f4043c9a83029c21855ff61b7601e611 (patch)
treee0e08eb9e6a168c65444dfc9751a522cb08b0ab3 /c-ares
downloadcibs-pkgs-98cb3b26f4043c9a83029c21855ff61b7601e611.tar.gz
Initial commit from cibs/examples
Diffstat (limited to 'c-ares')
-rw-r--r--c-ares/Makefile45
-rw-r--r--c-ares/c-ares.license10
-rw-r--r--c-ares/c-ares.p5m93
3 files changed, 148 insertions, 0 deletions
diff --git a/c-ares/Makefile b/c-ares/Makefile
new file mode 100644
index 0000000..66dfa3c
--- /dev/null
+++ b/c-ares/Makefile
@@ -0,0 +1,45 @@
+
+# We are going to package for IPS ;-)
+include /usr/share/cibs/rules/ips.mk
+
+# We are using tarball(s)
+include /usr/share/cibs/rules/archive.mk
+
+# We are using GNU configure
+include /usr/share/cibs/rules/autotools.mk
+
+# We will build 32-bit version
+include /usr/share/cibs/rules/32.mk
+
+# ... and 64-bit
+include /usr/share/cibs/rules/64.mk
+
+
+summary := C library that performs DNS requests and name resolves asynchronously
+license := MIT
+
+# build-depends +=
+# build-conflicts +=
+
+home := http://c-ares.haxx.se
+name := c-ares
+version := 1.9.1
+archive := $(name)-$(version).tar.gz
+download := $(home)/download/$(archive)
+checksum := \
+ sha1:fe41e47f300bfd587b7f552a141ad3bf85437b0f \
+ sha256:023f28001f2f839645c8700187391a011198950c73ddd91510c7549d87373936 \
+ md5:389db4917a3b58c4ce4ebfe961fd84c4 \
+ size:782945
+
+# archives := more.zip tarballs.tar.bz2
+# download_more.zip := ftp://...
+# download_tarballs.tar.bz2 := https://...
+# checksum_more.zip := ...
+# checksum_tarballs.tar.bz2 := ...
+#
+# patch::
+# autoreconf -vi
+
+
+
diff --git a/c-ares/c-ares.license b/c-ares/c-ares.license
new file mode 100644
index 0000000..f0a205f
--- /dev/null
+++ b/c-ares/c-ares.license
@@ -0,0 +1,10 @@
+Copyright 1998 by the Massachusetts Institute of Technology.
+
+Permission to use, copy, modify, and distribute this software and its
+documentation for any purpose and without fee is hereby granted, provided that
+the above copyright notice appear in all copies and that both that copyright
+notice and this permission notice appear in supporting documentation, and that
+the name of M.I.T. not be used in advertising or publicity pertaining to
+distribution of the software without specific, written prior permission.
+M.I.T. makes no representations about the suitability of this software for any
+purpose. It is provided "as is" without express or implied warranty.
diff --git a/c-ares/c-ares.p5m b/c-ares/c-ares.p5m
new file mode 100644
index 0000000..bc0efb9
--- /dev/null
+++ b/c-ares/c-ares.p5m
@@ -0,0 +1,93 @@
+#
+# CDDL HEADER START
+#
+# The contents of this file are subject to the terms of the
+# Common Development and Distribution License (the "License").
+# You may not use this file except in compliance with the License.
+#
+# You can obtain a copy of the license
+# at http://www.opensource.org/licenses/CDDL-1.0
+# See the License for the specific language governing permissions
+# and limitations under the License.
+#
+# When distributing Covered Code, include this CDDL HEADER in each file.
+# If applicable, add the following below this CDDL HEADER, with the
+# fields enclosed by brackets "[]" replaced with your own identifying
+# information: Portions Copyright [yyyy] [name of copyright owner]
+#
+# CDDL HEADER END
+#
+#
+# Copyright (C) 2012, Nexenta Systems, Inc. All rights reserved.
+#
+
+
+set name=pkg.fmri value=pkg:/library/c-ares@$(ips-version)
+set name=pkg.summary value="$(summary)"
+set name=info.upstream-url value="$(home)"
+set name=info.source_url value="$(download)"
+license c-ares.license license="$(license)"
+
+
+dir path=usr
+dir path=usr/lib
+dir path=usr/lib/$(MACH64)
+dir path=usr/lib/$(MACH64)/pkgconfig
+dir path=usr/lib/pkgconfig
+dir path=usr/share
+dir path=usr/share/man
+dir path=usr/share/man/man3
+dir path=usr/include
+file path=usr/lib/$(MACH64)/libcares.so.2.0.0
+file path=usr/lib/$(MACH64)/pkgconfig/libcares.pc
+file path=usr/lib/pkgconfig/libcares.pc
+file path=usr/lib/libcares.so.2.0.0
+file path=usr/share/man/man3/ares_parse_soa_reply.3
+file path=usr/share/man/man3/ares_timeout.3
+file path=usr/share/man/man3/ares_parse_ptr_reply.3
+file path=usr/share/man/man3/ares_query.3
+file path=usr/share/man/man3/ares_free_hostent.3
+file path=usr/share/man/man3/ares_free_data.3
+file path=usr/share/man/man3/ares_gethostbyname.3
+file path=usr/share/man/man3/ares_parse_mx_reply.3
+file path=usr/share/man/man3/ares_save_options.3
+file path=usr/share/man/man3/ares_expand_string.3
+file path=usr/share/man/man3/ares_get_servers.3
+file path=usr/share/man/man3/ares_parse_txt_reply.3
+file path=usr/share/man/man3/ares_library_cleanup.3
+file path=usr/share/man/man3/ares_parse_srv_reply.3
+file path=usr/share/man/man3/ares_version.3
+file path=usr/share/man/man3/ares_init_options.3
+file path=usr/share/man/man3/ares_init.3
+file path=usr/share/man/man3/ares_process.3
+file path=usr/share/man/man3/ares_cancel.3
+file path=usr/share/man/man3/ares_fds.3
+file path=usr/share/man/man3/ares_destroy.3
+file path=usr/share/man/man3/ares_parse_ns_reply.3
+file path=usr/share/man/man3/ares_parse_aaaa_reply.3
+file path=usr/share/man/man3/ares_parse_naptr_reply.3
+file path=usr/share/man/man3/ares_gethostbyaddr.3
+file path=usr/share/man/man3/ares_strerror.3
+file path=usr/share/man/man3/ares_gethostbyname_file.3
+file path=usr/share/man/man3/ares_free_string.3
+file path=usr/share/man/man3/ares_search.3
+file path=usr/share/man/man3/ares_parse_a_reply.3
+file path=usr/share/man/man3/ares_library_init.3
+file path=usr/share/man/man3/ares_set_socket_callback.3
+file path=usr/share/man/man3/ares_mkquery.3
+file path=usr/share/man/man3/ares_set_servers.3
+file path=usr/share/man/man3/ares_getnameinfo.3
+file path=usr/share/man/man3/ares_expand_name.3
+file path=usr/share/man/man3/ares_dup.3
+file path=usr/share/man/man3/ares_destroy_options.3
+file path=usr/share/man/man3/ares_getsock.3
+file path=usr/share/man/man3/ares_send.3
+file path=usr/include/ares_build.h
+file path=usr/include/ares_rules.h
+file path=usr/include/ares_dns.h
+file path=usr/include/ares_version.h
+file path=usr/include/ares.h
+link path=usr/lib/libcares.so target=libcares.so.2.0.0
+link path=usr/lib/$(MACH64)/libcares.so target=libcares.so.2.0.0
+link path=usr/lib/$(MACH64)/libcares.so.2 target=libcares.so.2.0.0
+link path=usr/lib/libcares.so.2 target=libcares.so.2.0.0