summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2012-12-07 08:15:12 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2012-12-07 08:15:12 +0400
commit6566e7e29f6c07002298b0286589a4bfa2d13d02 (patch)
tree4edc13256cd824e5fc9627dd2570676568b94724
parent5b5d939add5d90229333c89bee838289bfd1bdda (diff)
downloadcibs-pkgs-6566e7e29f6c07002298b0286589a4bfa2d13d02.tar.gz
Split library/ncurses AND ship binaries to replace SUNWcs
-rw-r--r--ncurses/Makefile2
-rw-r--r--ncurses/ncurses-base.p5m3
-rw-r--r--ncurses/ncurses-bin.p5m29
-rw-r--r--ncurses/ncurses.p5m31
-rw-r--r--ncurses/ncurses5.p5m31
5 files changed, 66 insertions, 30 deletions
diff --git a/ncurses/Makefile b/ncurses/Makefile
index 2eebd95..9acd2c0 100644
--- a/ncurses/Makefile
+++ b/ncurses/Makefile
@@ -44,7 +44,7 @@ configure-env.32 = \
PKG_CONFIG_LIBDIR="$(libdir.32)/pkgconfig"
configure-options.32 = \
--without-manpages \
- --without-progs
+ --with-progs
configure-env.64 = \
PKG_CONFIG_LIBDIR="$(libdir.64)/pkgconfig"
diff --git a/ncurses/ncurses-base.p5m b/ncurses/ncurses-base.p5m
index 2842d65..41b7e6c 100644
--- a/ncurses/ncurses-base.p5m
+++ b/ncurses/ncurses-base.p5m
@@ -6,6 +6,9 @@ set name=info.source-url value="$(download)"
license $(license-file) license="$(license)"
<transform file path=etc/.* -> set action.hash %(path) >
+
+
+# NOTE: moving from /etc into /lib
<transform file path=etc/.* -> edit path etc/ lib/ >
file path=etc/terminfo/E/Eterm
diff --git a/ncurses/ncurses-bin.p5m b/ncurses/ncurses-bin.p5m
new file mode 100644
index 0000000..0cac79d
--- /dev/null
+++ b/ncurses/ncurses-bin.p5m
@@ -0,0 +1,29 @@
+set name=pkg.fmri value=pkg:/runtime/$(name)-bin@$(ips-version)
+set name=pkg.summary value="$(summary), terminal-related programs and man pages"
+set name=info.upstream-url value="$(home)"
+set name=info.source-url value="$(download)"
+
+license $(license-file) license="$(license)"
+
+file path=usr/bin/clear
+file path=usr/bin/infocmp
+file path=usr/bin/ncurses5-config facet.devel=true
+file path=usr/bin/tabs
+file path=usr/bin/tic facet.devel=true
+file path=usr/bin/toe
+file path=usr/bin/tput
+file path=usr/bin/tset
+file path=usr/share/man/man1/captoinfo.1m
+file path=usr/share/man/man1/clear.1
+file path=usr/share/man/man1/infocmp.1m
+file path=usr/share/man/man1/infotocap.1m
+file path=usr/share/man/man1/ncurses5-config.1 facet.devel=true
+file path=usr/share/man/man1/tabs.1
+file path=usr/share/man/man1/tic.1m facet.devel=true
+file path=usr/share/man/man1/toe.1m
+file path=usr/share/man/man1/tput.1
+file path=usr/share/man/man1/tset.1
+link path=usr/bin/captoinfo target=tic
+link path=usr/bin/infotocap target=tic
+link path=usr/bin/reset target=tset
+link path=usr/share/man/man1/reset.1 target=tset.1
diff --git a/ncurses/ncurses.p5m b/ncurses/ncurses.p5m
index e99319f..8dc6f59 100644
--- a/ncurses/ncurses.p5m
+++ b/ncurses/ncurses.p5m
@@ -5,11 +5,8 @@ set name=info.source-url value="$(download)"
license $(license-file) license="$(license)"
-<transform file link path=.+/lib/.+ -> \
- default original_name system/library >
-
-<transform file link path=.+/include/.+ -> \
- default original_name pkg:/system/header >
+depend fmri=pkg:/library/$(name)5@$(ips-version) type=require
+depend fmri=pkg:/library/$(name)5@$(ips-version) type=incorporate
dir path=usr/include
dir path=usr/lib/$(MACH64)
@@ -34,24 +31,12 @@ file path=usr/include/term_entry.h
file path=usr/include/termcap.h
file path=usr/include/tic.h
file path=usr/include/unctrl.h
-file path=usr/lib/$(MACH64)/libform.so.5.9
-file path=usr/lib/$(MACH64)/libmenu.so.5.9
-file path=usr/lib/$(MACH64)/libncurses.so.5.9
-file path=usr/lib/$(MACH64)/libpanel.so.5.9
-file path=usr/lib/$(MACH64)/libtic.so.5.9
-file path=usr/lib/$(MACH64)/libtinfo.so.5.9
file path=usr/lib/$(MACH64)/pkgconfig/form.pc
file path=usr/lib/$(MACH64)/pkgconfig/menu.pc
file path=usr/lib/$(MACH64)/pkgconfig/ncurses.pc
file path=usr/lib/$(MACH64)/pkgconfig/panel.pc
file path=usr/lib/$(MACH64)/pkgconfig/tic.pc
file path=usr/lib/$(MACH64)/pkgconfig/tinfo.pc
-file path=usr/lib/libform.so.5.9
-file path=usr/lib/libmenu.so.5.9
-file path=usr/lib/libncurses.so.5.9
-file path=usr/lib/libpanel.so.5.9
-file path=usr/lib/libtic.so.5.9
-file path=usr/lib/libtinfo.so.5.9
file path=usr/lib/pkgconfig/form.pc
file path=usr/lib/pkgconfig/menu.pc
file path=usr/lib/pkgconfig/ncurses.pc
@@ -61,27 +46,15 @@ file path=usr/lib/pkgconfig/tinfo.pc
link path=usr/include/ncurses.h target=curses.h
link path=usr/lib/$(MACH64)/libcurses.so target=libncurses.so.5.9
link path=usr/lib/$(MACH64)/libform.so target=libform.so.5
-link path=usr/lib/$(MACH64)/libform.so.5 target=libform.so.5.9
link path=usr/lib/$(MACH64)/libmenu.so target=libmenu.so.5
-link path=usr/lib/$(MACH64)/libmenu.so.5 target=libmenu.so.5.9
link path=usr/lib/$(MACH64)/libncurses.so target=libncurses.so.5
-link path=usr/lib/$(MACH64)/libncurses.so.5 target=libncurses.so.5.9
link path=usr/lib/$(MACH64)/libpanel.so target=libpanel.so.5
-link path=usr/lib/$(MACH64)/libpanel.so.5 target=libpanel.so.5.9
link path=usr/lib/$(MACH64)/libtic.so target=libtic.so.5
-link path=usr/lib/$(MACH64)/libtic.so.5 target=libtic.so.5.9
link path=usr/lib/$(MACH64)/libtinfo.so target=libtinfo.so.5
-link path=usr/lib/$(MACH64)/libtinfo.so.5 target=libtinfo.so.5.9
link path=usr/lib/libcurses.so target=libncurses.so.5.9
link path=usr/lib/libform.so target=libform.so.5
-link path=usr/lib/libform.so.5 target=libform.so.5.9
link path=usr/lib/libmenu.so target=libmenu.so.5
-link path=usr/lib/libmenu.so.5 target=libmenu.so.5.9
link path=usr/lib/libncurses.so target=libncurses.so.5
-link path=usr/lib/libncurses.so.5 target=libncurses.so.5.9
link path=usr/lib/libpanel.so target=libpanel.so.5
-link path=usr/lib/libpanel.so.5 target=libpanel.so.5.9
link path=usr/lib/libtic.so target=libtic.so.5
-link path=usr/lib/libtic.so.5 target=libtic.so.5.9
link path=usr/lib/libtinfo.so target=libtinfo.so.5
-link path=usr/lib/libtinfo.so.5 target=libtinfo.so.5.9
diff --git a/ncurses/ncurses5.p5m b/ncurses/ncurses5.p5m
new file mode 100644
index 0000000..a19ce20
--- /dev/null
+++ b/ncurses/ncurses5.p5m
@@ -0,0 +1,31 @@
+set name=pkg.fmri value=pkg:/library/$(name)5@$(ips-version)
+set name=pkg.summary value="$(summary), shared libraries"
+set name=info.upstream-url value="$(home)"
+set name=info.source-url value="$(download)"
+
+license $(license-file) license="$(license)"
+
+file path=usr/lib/$(MACH64)/libform.so.5.9
+file path=usr/lib/$(MACH64)/libmenu.so.5.9
+file path=usr/lib/$(MACH64)/libncurses.so.5.9
+file path=usr/lib/$(MACH64)/libpanel.so.5.9
+file path=usr/lib/$(MACH64)/libtic.so.5.9
+file path=usr/lib/$(MACH64)/libtinfo.so.5.9
+file path=usr/lib/libform.so.5.9
+file path=usr/lib/libmenu.so.5.9
+file path=usr/lib/libncurses.so.5.9
+file path=usr/lib/libpanel.so.5.9
+file path=usr/lib/libtic.so.5.9
+file path=usr/lib/libtinfo.so.5.9
+link path=usr/lib/$(MACH64)/libform.so.5 target=libform.so.5.9
+link path=usr/lib/$(MACH64)/libmenu.so.5 target=libmenu.so.5.9
+link path=usr/lib/$(MACH64)/libncurses.so.5 target=libncurses.so.5.9
+link path=usr/lib/$(MACH64)/libpanel.so.5 target=libpanel.so.5.9
+link path=usr/lib/$(MACH64)/libtic.so.5 target=libtic.so.5.9
+link path=usr/lib/$(MACH64)/libtinfo.so.5 target=libtinfo.so.5.9
+link path=usr/lib/libform.so.5 target=libform.so.5.9
+link path=usr/lib/libmenu.so.5 target=libmenu.so.5.9
+link path=usr/lib/libncurses.so.5 target=libncurses.so.5.9
+link path=usr/lib/libpanel.so.5 target=libpanel.so.5.9
+link path=usr/lib/libtic.so.5 target=libtic.so.5.9
+link path=usr/lib/libtinfo.so.5 target=libtinfo.so.5.9