summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2012-12-21 08:45:06 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2012-12-21 08:45:06 +0400
commit393ab6c1711c8f487bfb32dc01cb77aafa86b2f0 (patch)
tree5daa2bf59f2bde48ed6bbd4b0781017d92eec08e
parenta5d2fc3a6eee3f0191f19501fcddd4ded31d6405 (diff)
downloadcibs-pkgs-393ab6c1711c8f487bfb32dc01cb77aafa86b2f0.tar.gz
Rename ZeroMQ packages, build only 64-bit
-rw-r--r--zeromq/Makefile3
-rw-r--r--zeromq/libzmq.p5m (renamed from zeromq/zeromq.p5m)12
-rw-r--r--zeromq/libzmq1.p5m9
-rw-r--r--zeromq/zeromq1.p5m11
4 files changed, 15 insertions, 20 deletions
diff --git a/zeromq/Makefile b/zeromq/Makefile
index 4149575..4270f36 100644
--- a/zeromq/Makefile
+++ b/zeromq/Makefile
@@ -1,7 +1,6 @@
include /usr/share/cibs/rules/ips.mk
include /usr/share/cibs/rules/archive.mk
include /usr/share/cibs/rules/autotools.mk
-include /usr/share/cibs/rules/32.mk
include /usr/share/cibs/rules/64.mk
# man pages are not installed if building out of source tree:
@@ -18,7 +17,7 @@ build-depends += \
#/usr/gcc/4.3/bin/gcc -m32 -luuid -o test
#ld: warning: file libdladm.so.1: required by /usr/lib/libdlpi.so.1, not found
-configure-env += LDFLAGS="-L/lib"
+configure-env.32 += LDFLAGS="-L/lib"
configure-options += --with-system-pgm
diff --git a/zeromq/zeromq.p5m b/zeromq/libzmq.p5m
index ddc97c6..0b547b2 100644
--- a/zeromq/zeromq.p5m
+++ b/zeromq/libzmq.p5m
@@ -1,18 +1,17 @@
-set name=pkg.fmri value=pkg:/library/zeromq@$(ips-version)
+set name=pkg.fmri value=pkg:/library/libzmq@$(ips-version)
set name=pkg.summary value="$(summary)"
set name=info.upstream-url value="$(home)"
set name=info.source-url value="$(download)"
license $(license-file) license="$(license)"
-depend fmri=pkg:/library/zeromq1@$(ips-version) type=require
-depend fmri=pkg:/library/zeromq1@$(ips-version) type=incorporate
+depend fmri=pkg:/library/libzmq1@$(ips-version) type=require
+depend fmri=pkg:/library/libzmq1@$(ips-version) type=incorporate
file path=usr/include/zmq.h
file path=usr/include/zmq.hpp
file path=usr/include/zmq_utils.h
-file path=usr/lib/$(MACH64)/pkgconfig/libzmq.pc
-file path=usr/lib/pkgconfig/libzmq.pc
+file path=usr/lib/$(mach64)/pkgconfig/libzmq.pc
file path=usr/share/man/man3/zmq_bind.3
file path=usr/share/man/man3/zmq_close.3
file path=usr/share/man/man3/zmq_connect.3
@@ -43,5 +42,4 @@ file path=usr/share/man/man7/zmq_inproc.7
file path=usr/share/man/man7/zmq_ipc.7
file path=usr/share/man/man7/zmq_pgm.7
file path=usr/share/man/man7/zmq_tcp.7
-link path=usr/lib/$(MACH64)/libzmq.so target=libzmq.so.1.0.1
-link path=usr/lib/libzmq.so target=libzmq.so.1.0.1
+link path=usr/lib/$(mach64)/libzmq.so target=libzmq.so.1
diff --git a/zeromq/libzmq1.p5m b/zeromq/libzmq1.p5m
new file mode 100644
index 0000000..3f23d45
--- /dev/null
+++ b/zeromq/libzmq1.p5m
@@ -0,0 +1,9 @@
+set name=pkg.fmri value=pkg:/library/libzmq1@$(ips-version)
+set name=pkg.summary value="$(summary), shared library"
+set name=info.upstream-url value="$(home)"
+set name=info.source-url value="$(download)"
+
+license $(license-file) license="$(license)"
+
+file path=usr/lib/$(mach64)/libzmq.so.1.0.1
+link path=usr/lib/$(mach64)/libzmq.so.1 target=libzmq.so.1.0.1
diff --git a/zeromq/zeromq1.p5m b/zeromq/zeromq1.p5m
deleted file mode 100644
index eda1df1..0000000
--- a/zeromq/zeromq1.p5m
+++ /dev/null
@@ -1,11 +0,0 @@
-set name=pkg.fmri value=pkg:/library/zeromq1@$(ips-version)
-set name=pkg.summary value="$(summary)"
-set name=info.upstream-url value="$(home)"
-set name=info.source-url value="$(download)"
-
-license $(license-file) license="$(license)"
-
-file path=usr/lib/$(MACH64)/libzmq.so.1.0.1
-file path=usr/lib/libzmq.so.1.0.1
-link path=usr/lib/$(MACH64)/libzmq.so.1 target=libzmq.so.1.0.1
-link path=usr/lib/libzmq.so.1 target=libzmq.so.1.0.1