summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2012-12-05 09:41:11 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2012-12-05 09:41:11 +0400
commit10dfc69073ddd934e5744ed17f24ae11d45fbc12 (patch)
treea0ade7274a9972bd1aa5690b6757fa461d82ea7d
parentcc9db92fc612dcd596d59f9ff32fc79b806005e7 (diff)
downloadcibs-pkgs-10dfc69073ddd934e5744ed17f24ae11d45fbc12.tar.gz
libffi
-rw-r--r--libffi/Makefile20
-rw-r--r--libffi/libffi.p5m31
-rw-r--r--libffi/libffi6.p5m12
3 files changed, 63 insertions, 0 deletions
diff --git a/libffi/Makefile b/libffi/Makefile
new file mode 100644
index 0000000..a1006e7
--- /dev/null
+++ b/libffi/Makefile
@@ -0,0 +1,20 @@
+include /usr/share/cibs/rules/ips.mk
+include /usr/share/cibs/rules/archive.mk
+include /usr/share/cibs/rules/autotools.mk
+include /usr/share/cibs/rules/32.mk
+include /usr/share/cibs/rules/64.mk
+
+summary := A Portable Foreign Function Interface Library
+license := X11
+license-file := LICENSE
+
+name := libffi
+home := http://sourceware.org/libffi/
+version := 3.0.11
+archive := $(name)-$(version).tar.gz
+download := ftp://sourceware.org/pub/$(name)/$(archive)
+checksum := \
+ md5:f69b9693227d976835b4857b1ba7d0e3 \
+ sha1:bff6a6c886f90ad5e30dee0b46676e8e0297d81d \
+ sha256:70bfb01356360089aa97d3e71e3edf05d195599fd822e922e50d46a0055a6283 \
+ size:794220
diff --git a/libffi/libffi.p5m b/libffi/libffi.p5m
new file mode 100644
index 0000000..fedc405
--- /dev/null
+++ b/libffi/libffi.p5m
@@ -0,0 +1,31 @@
+set name=pkg.fmri value=pkg:/library/libffi@$(ips-version)
+set name=pkg.summary value="$(summary)"
+set name=info.upstream-url value="$(home)"
+set name=info.source-url value="$(download)"
+
+license $(license-file) license="$(license)"
+
+depend fmri=pkg:/library/libffi6@$(ips-version) type=require
+depend fmri=pkg:/library/libffi6@$(ips-version) type=incorporate
+
+dir path=usr
+dir path=usr/lib
+dir path=usr/lib/$(MACH64)
+dir path=usr/lib/$(MACH64)/libffi-3.0.11
+dir path=usr/lib/$(MACH64)/libffi-3.0.11/include
+dir path=usr/lib/$(MACH64)/pkgconfig
+dir path=usr/share
+dir path=usr/share/info
+dir path=usr/share/man
+dir path=usr/share/man/man3
+file path=usr/lib/$(MACH64)/libffi-3.0.11/include/ffi.h
+file path=usr/lib/$(MACH64)/libffi-3.0.11/include/ffitarget.h
+file path=usr/lib/$(MACH64)/pkgconfig/libffi.pc
+file path=usr/share/info/libffi.info
+file path=usr/share/man/man3/ffi.3
+file path=usr/share/man/man3/ffi_call.3
+file path=usr/share/man/man3/ffi_prep_cif.3
+file path=usr/share/man/man3/ffi_prep_cif_var.3
+link path=usr/lib/$(MACH64)/libffi.so target=libffi.so.6.0.0
+link path=usr/lib/libffi.so target=libffi.so.6.0.0
+
diff --git a/libffi/libffi6.p5m b/libffi/libffi6.p5m
new file mode 100644
index 0000000..dd65fc4
--- /dev/null
+++ b/libffi/libffi6.p5m
@@ -0,0 +1,12 @@
+set name=pkg.fmri value=pkg:/library/libffi6@$(ips-version)
+set name=pkg.summary value="$(summary), shared library"
+set name=info.upstream-url value="$(home)"
+set name=info.source-url value="$(download)"
+
+license $(license-file) license="$(license)"
+
+file path=usr/lib/$(MACH64)/libffi.so.6.0.0
+file path=usr/lib/libffi.so.6.0.0
+link path=usr/lib/$(MACH64)/libffi.so.6 target=libffi.so.6.0.0
+link path=usr/lib/libffi.so.6 target=libffi.so.6.0.0
+