summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Pashev <igor.pashev@nexenta.com>2012-12-10 16:40:37 +0400
committerIgor Pashev <igor.pashev@nexenta.com>2012-12-10 16:40:37 +0400
commit0f1bbbc58b9392e7e2927d330eb8cf83179be387 (patch)
tree26dbc92f99b3b82084bab1fb391925354ec89cb2
parentd3b91db21115c0645281e1322eb1798391f47b19 (diff)
downloadcibs-pkgs-0f1bbbc58b9392e7e2927d330eb8cf83179be387.tar.gz
Split zeromq, add man pages, 32-bit
-rw-r--r--zeromq/Makefile7
-rw-r--r--zeromq/zeromq.p5m50
-rw-r--r--zeromq/zeromq1.p5m11
3 files changed, 52 insertions, 16 deletions
diff --git a/zeromq/Makefile b/zeromq/Makefile
index 38dadef..4149575 100644
--- a/zeromq/Makefile
+++ b/zeromq/Makefile
@@ -1,15 +1,20 @@
include /usr/share/cibs/rules/ips.mk
include /usr/share/cibs/rules/archive.mk
include /usr/share/cibs/rules/autotools.mk
+include /usr/share/cibs/rules/32.mk
include /usr/share/cibs/rules/64.mk
+# man pages are not installed if building out of source tree:
+include /usr/share/cibs/rules/copy.mk
+
summary := The ZeroMQ messaging library
license := LGPL
license-file := COPYING.LESSER
build-depends += \
- pkg:/library/libpgm
+ library/libpgm \
+ developer/pkg-config
#/usr/gcc/4.3/bin/gcc -m32 -luuid -o test
#ld: warning: file libdladm.so.1: required by /usr/lib/libdlpi.so.1, not found
diff --git a/zeromq/zeromq.p5m b/zeromq/zeromq.p5m
index aa78982..ddc97c6 100644
--- a/zeromq/zeromq.p5m
+++ b/zeromq/zeromq.p5m
@@ -1,27 +1,47 @@
set name=pkg.fmri value=pkg:/library/zeromq@$(ips-version)
set name=pkg.summary value="$(summary)"
set name=info.upstream-url value="$(home)"
-set name=info.source_url value="$(download)"
+set name=info.source-url value="$(download)"
+
license $(license-file) license="$(license)"
-dir path=usr
-dir path=usr/include
-dir path=usr/lib
-dir path=usr/lib/$(MACH64)
-dir path=usr/lib/$(MACH64)/pkgconfig
-dir path=usr/lib/pkgconfig
-dir path=usr/share
-dir path=usr/share/man
-dir path=usr/share/man/man3
-dir path=usr/share/man/man7
+depend fmri=pkg:/library/zeromq1@$(ips-version) type=require
+depend fmri=pkg:/library/zeromq1@$(ips-version) type=incorporate
+
file path=usr/include/zmq.h
file path=usr/include/zmq.hpp
file path=usr/include/zmq_utils.h
-file path=usr/lib/$(MACH64)/libzmq.so.1.0.1
file path=usr/lib/$(MACH64)/pkgconfig/libzmq.pc
-file path=usr/lib/libzmq.so.1.0.1
file path=usr/lib/pkgconfig/libzmq.pc
+file path=usr/share/man/man3/zmq_bind.3
+file path=usr/share/man/man3/zmq_close.3
+file path=usr/share/man/man3/zmq_connect.3
+file path=usr/share/man/man3/zmq_device.3
+file path=usr/share/man/man3/zmq_errno.3
+file path=usr/share/man/man3/zmq_getsockopt.3
+file path=usr/share/man/man3/zmq_init.3
+file path=usr/share/man/man3/zmq_msg_close.3
+file path=usr/share/man/man3/zmq_msg_copy.3
+file path=usr/share/man/man3/zmq_msg_data.3
+file path=usr/share/man/man3/zmq_msg_init.3
+file path=usr/share/man/man3/zmq_msg_init_data.3
+file path=usr/share/man/man3/zmq_msg_init_size.3
+file path=usr/share/man/man3/zmq_msg_move.3
+file path=usr/share/man/man3/zmq_msg_size.3
+file path=usr/share/man/man3/zmq_poll.3
+file path=usr/share/man/man3/zmq_recv.3
+file path=usr/share/man/man3/zmq_send.3
+file path=usr/share/man/man3/zmq_setsockopt.3
+file path=usr/share/man/man3/zmq_socket.3
+file path=usr/share/man/man3/zmq_strerror.3
+file path=usr/share/man/man3/zmq_term.3
+file path=usr/share/man/man3/zmq_version.3
+file path=usr/share/man/man7/zmq.7
+file path=usr/share/man/man7/zmq_cpp.7
+file path=usr/share/man/man7/zmq_epgm.7
+file path=usr/share/man/man7/zmq_inproc.7
+file path=usr/share/man/man7/zmq_ipc.7
+file path=usr/share/man/man7/zmq_pgm.7
+file path=usr/share/man/man7/zmq_tcp.7
link path=usr/lib/$(MACH64)/libzmq.so target=libzmq.so.1.0.1
-link path=usr/lib/$(MACH64)/libzmq.so.1 target=libzmq.so.1.0.1
link path=usr/lib/libzmq.so target=libzmq.so.1.0.1
-link path=usr/lib/libzmq.so.1 target=libzmq.so.1.0.1
diff --git a/zeromq/zeromq1.p5m b/zeromq/zeromq1.p5m
new file mode 100644
index 0000000..eda1df1
--- /dev/null
+++ b/zeromq/zeromq1.p5m
@@ -0,0 +1,11 @@
+set name=pkg.fmri value=pkg:/library/zeromq1@$(ips-version)
+set name=pkg.summary value="$(summary)"
+set name=info.upstream-url value="$(home)"
+set name=info.source-url value="$(download)"
+
+license $(license-file) license="$(license)"
+
+file path=usr/lib/$(MACH64)/libzmq.so.1.0.1
+file path=usr/lib/libzmq.so.1.0.1
+link path=usr/lib/$(MACH64)/libzmq.so.1 target=libzmq.so.1.0.1
+link path=usr/lib/libzmq.so.1 target=libzmq.so.1.0.1