aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authordos-reis <gdr@axiomatics.org>2010-11-29 08:21:05 +0000
committerdos-reis <gdr@axiomatics.org>2010-11-29 08:21:05 +0000
commiteaf9fdfc5fb7d296c16df34384914e0a62639314 (patch)
treec7af850bfc35fd4f5673b90fa3dd14c5ede4d2eb /src/Makefile.am
parentdea4d75caba3466cdc8595d333c31a5393912c69 (diff)
downloadopen-axiom-eaf9fdfc5fb7d296c16df34384914e0a62639314.tar.gz
Add support for translator and linker in the driver
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index de5ad770..b56fa7e1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -37,6 +37,11 @@ DIST_SUBDIRS = \
lisp scripts share sman \
testsuite utils
+subdirs = \
+ algebra boot clef doc driver \
+ etc graph hyper input interp \
+ lib lisp share sman utils
+
oa_targetdir = $(top_builddir)/$(target)
if OA_BUILD_SMAN
@@ -134,4 +139,17 @@ all-check:
cd input && $(MAKE) $(AM_MAKEFLAGS) all-check
mostlyclean-local:
+ for d in $(subdirs); do \
+ (cd $$d && $(MAKE) $(AM_MAKEFLAGS) mostlyclean); \
+ done
-rm -f stamp-subdirs
+
+clean-local:
+ for d in $(subdirs); do \
+ (cd $$d && $(MAKE) $(AM_MAKEFLAGS) clean); \
+ done
+
+distclean-local:
+ for d in $(subdirs); do \
+ (cd $$d && $(MAKE) $(AM_MAKEFLAGS) distclean); \
+ done