aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordos-reis <gdr@axiomatics.org>2014-08-26 10:07:17 +0000
committerdos-reis <gdr@axiomatics.org>2014-08-26 10:07:17 +0000
commitef059f3f675f384c68c15076dbcf220be1e01eee (patch)
tree08124f18e4f7a3044b719ae860e3b492ed704287 /configure.ac
parentcfffc75b762f4364623f85a887b7e564421e3127 (diff)
downloadopen-axiom-ef059f3f675f384c68c15076dbcf220be1e01eee.tar.gz
Add generic Boot and Spad tokenizer.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 035e7931..ffdec895 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,7 +33,7 @@ dnl Makefiles for building OpenAxiom interpreter, compiler, libraries, and
dnl auxiliary tools where appropriate.
dnl
-AC_INIT([OpenAxiom], [1.5.0-2014-08-16],
+AC_INIT([OpenAxiom], [1.5.0-2014-08-26],
[open-axiom-bugs@lists.sf.net])
dnl Most of the macros used in this configure.ac are defined in files
@@ -41,6 +41,10 @@ dnl located in the subdirectory config/
AC_CONFIG_AUX_DIR([config])
AC_CONFIG_MACRO_DIR([config])
+AH_TOP([#ifndef OPENAXIOM_CONFIG_included]
+[#define OPENAXIOM_CONFIG_included])
+AH_BOTTOM([#endif // OPENAXIOM_CONFIG_included])
+
dnl Put all configuration macros here
AC_CONFIG_HEADERS([config/openaxiom-c-macros.h])
@@ -109,6 +113,7 @@ OPENAXIOM_FFI_TYPE_TABLE
OPENAXIOM_GCL_BUILD_OPTIONS
OPENAXIOM_CHECK_MM
OPENAXIOM_CHECK_MISC
+OPENAXIOM_LINK_FILES
## We are ready to instantiate makefiles.
AC_CONFIG_FILES([
@@ -139,6 +144,10 @@ OPENAXIOM_MAKEFILE([src/graph/viewAlone/Makefile])
OPENAXIOM_MAKEFILE([src/graph/viewman/Makefile])
AC_CONFIG_FILES([src/gui/gui.pro])
+AC_CONFIG_COMMANDS([$target/include/open-axiom/config],
+ [cp -p config/openaxiom-c-macros.h $target/include/open-axiom/config],
+ [target=$target])
+
AC_OUTPUT
## Set up Makefile for QT-based gui