aboutsummaryrefslogtreecommitdiff
path: root/modules/apps/logrotate.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/apps/logrotate.nix')
-rw-r--r--modules/apps/logrotate.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/modules/apps/logrotate.nix b/modules/apps/logrotate.nix
index e7e360a..ba4ca5b 100644
--- a/modules/apps/logrotate.nix
+++ b/modules/apps/logrotate.nix
@@ -6,7 +6,7 @@ let
elem isBool isString ;
inherit (lib)
- concatMapStringsSep concatStringsSep filter filterAttrs flatten
+ concatMapStringsSep concatStringsSep filter filterAttrs
mapAttrsToList mkIf mkOption optionalString ;
inherit (lib.types)
@@ -21,7 +21,7 @@ let
mkConf = name: opts:
let
- files = concatMapStringsSep " " (f: ''"${f}"'') (flatten [opts.files]);
+ files = concatMapStringsSep " " (f: ''"${f}"'') opts.files;
show = k: v:
if elem k ["postrotate" "preremove" "prerotate"]
then " ${k}\n ${v}\n endscript"
@@ -48,7 +48,7 @@ let
entry = {
options = {
- files = mandatory (either path (listOf path));
+ files = mandatory (listOf path);
directives = {
compress = optional bool;
compresscmd = optional path;