summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index e3074ba..b70d418 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,11 +1,11 @@
#!/usr/bin/make -f
+include /usr/share/dpkg/architecture.mk
+
# make clean does not clean properly, so building out of source
BUILD = $(CURDIR)/build-tree
-LDFLAGS = -Wl,--as-needed
-
-DEB_HOST_ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH)
+LDFLAGS += -Wl,--as-needed
# List of archs currently having SBCL
# Keep build-deb on sbcl in one line: sbcl (...) [...],