summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules20
1 files changed, 9 insertions, 11 deletions
diff --git a/debian/rules b/debian/rules
index 1bd18cc..e5597c2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,7 +2,6 @@
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
-
include /usr/share/dpkg/architecture.mk
export DH_VERBOSE = 1
@@ -15,22 +14,21 @@ LISP := sbcl
oa_libdir := /usr/lib/open-axiom
+
PACKAGE := open-axiom
-SVN_REPO := svn://svn.code.sf.net/p/open-axiom/code/trunk
+GIT_REPO := https://github.com/GabrielDosReis/open-axiom.git
DEBIAN_PATH := $(abspath $(dir $(firstword $(MAKEFILE_LIST))))
SRC_VERSION := $(shell dpkg-parsechangelog -l$(DEBIAN_PATH)/changelog | awk '/^Version:/ {sub(/-[^-]*/, "", $$2); print $$2}')
-SVN_REVISION := $(shell echo $(SRC_VERSION) | sed -r 's,.+svn([0-9]+).*,\1,')
+GIT_REVISION := $(shell echo $(SRC_VERSION) | sed -r 's,.+git\.(\w+).*,\1,')
TARBALL := $(PACKAGE)_$(SRC_VERSION).orig.tar.xz
.PHONY: get-orig-source
get-orig-source:
- rm -rf get-orig-source $(TARBALL)
- mkdir get-orig-source
- svn export -r $(SVN_REVISION) $(SVN_REPO) \
- get-orig-source/$(PACKAGE)-$(SRC_VERSION)
- tar cJf $(TARBALL) -C get-orig-source \
- --exclude=contrib \
- $(PACKAGE)-$(SRC_VERSION)
- @rm -rf get-orig-source
+ rm -rf get-orig-source $(TARBALL) && mkdir get-orig-source
+ git clone $(GIT_REPO) get-orig-source/$(PACKAGE)-$(SRC_VERSION)
+ git -C get-orig-source/$(PACKAGE)-$(SRC_VERSION) checkout $(GIT_REVISION)
+ find get-orig-source/$(PACKAGE)-$(SRC_VERSION) -name '.*' -print0 | xargs -0 --no-run-if-empty rm -rfv
+ tar cJf $(TARBALL) -C get-orig-source $(PACKAGE)-$(SRC_VERSION)
+ rm -rf get-orig-source
@echo " "$(TARBALL)" created; move it to the right destination to build the package"
debian/open-axiom.1: build-stamp