summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2022-10-27 09:46:07 +0200
committerIgor Pashev <pashev.igor@gmail.com>2022-10-27 11:19:07 +0200
commitc5ad9e230e93ada3c5284acdc1db175467a31518 (patch)
tree8c07968a87b3923a7302a1e10788e4b5ec52ac00 /debian/rules
parentf013b33fdbc11942f1178763ca1f65aa4d05a138 (diff)
downloadopen-axiom-debian-c5ad9e230e93ada3c5284acdc1db175467a31518.tar.gz
open-axiom (1.5.0+2022.09.17.git.be9640c+ds-0pin1)
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules20
1 files changed, 7 insertions, 13 deletions
diff --git a/debian/rules b/debian/rules
index e5597c2..59150f4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -21,12 +21,16 @@ DEBIAN_PATH := $(abspath $(dir $(firstword $(MAKEFILE_LIST))))
SRC_VERSION := $(shell dpkg-parsechangelog -l$(DEBIAN_PATH)/changelog | awk '/^Version:/ {sub(/-[^-]*/, "", $$2); print $$2}')
GIT_REVISION := $(shell echo $(SRC_VERSION) | sed -r 's,.+git\.(\w+).*,\1,')
TARBALL := $(PACKAGE)_$(SRC_VERSION).orig.tar.xz
+DELETE = \
+ contrib/windows-installer \
+
.PHONY: get-orig-source
get-orig-source:
rm -rf get-orig-source $(TARBALL) && mkdir get-orig-source
git clone $(GIT_REPO) get-orig-source/$(PACKAGE)-$(SRC_VERSION)
git -C get-orig-source/$(PACKAGE)-$(SRC_VERSION) checkout $(GIT_REVISION)
find get-orig-source/$(PACKAGE)-$(SRC_VERSION) -name '.*' -print0 | xargs -0 --no-run-if-empty rm -rfv
+ cd get-orig-source/$(PACKAGE)-$(SRC_VERSION) && rm -rfv $(DELETE)
tar cJf $(TARBALL) -C get-orig-source $(PACKAGE)-$(SRC_VERSION)
rm -rf get-orig-source
@echo " "$(TARBALL)" created; move it to the right destination to build the package"
@@ -38,17 +42,12 @@ debian/open-axiom.1: build-stamp
-n 'open source platform for symbolic, algebraic, and numerical computations' \
$(BUILD)/src/driver/open-axiom > $@
-# --disable-gcl is for included GCL:
configure-stamp:
dh_testdir
- dh_autotools-dev_updateconfig
- # aclocal.m4 is older than configure; rebuilding aclocal.m4 requires aclocal-1.13
- touch aclocal.m4 config/*.m4 -r configure.ac
$(LISP) --version </dev/null || true
dh_auto_configure -B $(BUILD) -- \
--with-lisp=$(LISP) \
- --with-x \
- --disable-gcl
+ --with-x
touch $@
build: build-arch build-indep
@@ -97,10 +96,7 @@ else ifeq ($(LISP), gcl)
endif
dh_install
dh_installman
- dh_installdocs -p open-axiom-graphics --link-doc=open-axiom
- dh_installdocs -p open-axiom-test --link-doc=open-axiom
- dh_installdocs -p open-axiom-hypertex --link-doc=open-axiom
- dh_installdocs --remaining-packages
+ dh_installdocs
dh_installexamples
dh_installchangelogs
dh_installmenu
@@ -118,12 +114,10 @@ endif
dh_buildinfo
dh_lintian
dh_md5sums
- dh_builddeb -- -Zxz
+ dh_builddeb
clean:
dh_testdir
- dh_testroot
rm -rf $(BUILD)
- dh_autotools-dev_restoreconfig
dh_clean