summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2013-11-02 22:33:24 +0400
committerIgor Pashev <pashev.igor@gmail.com>2013-11-02 22:33:24 +0400
commitb45bdcb17e6d57617b0fbabb2900ef00a153a301 (patch)
tree203663abb48285e998d4f616f6b57aa95c32aaed /debian/rules
parent6b6e7cad74b1c439d3853b8737a2f4f0e37f3a57 (diff)
downloadopen-axiom-debian-b45bdcb17e6d57617b0fbabb2900ef00a153a301.tar.gz
Omit contrib in source tarball
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 2 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 2ec1007..1bd18cc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -19,7 +19,7 @@ PACKAGE := open-axiom
SVN_REPO := svn://svn.code.sf.net/p/open-axiom/code/trunk
DEBIAN_PATH := $(abspath $(dir $(firstword $(MAKEFILE_LIST))))
SRC_VERSION := $(shell dpkg-parsechangelog -l$(DEBIAN_PATH)/changelog | awk '/^Version:/ {sub(/-[^-]*/, "", $$2); print $$2}')
-SVN_REVISION := $(shell echo $(SRC_VERSION) | sed -r 's,.+svn([0-9]+),\1,')
+SVN_REVISION := $(shell echo $(SRC_VERSION) | sed -r 's,.+svn([0-9]+).*,\1,')
TARBALL := $(PACKAGE)_$(SRC_VERSION).orig.tar.xz
.PHONY: get-orig-source
get-orig-source:
@@ -28,6 +28,7 @@ get-orig-source:
svn export -r $(SVN_REVISION) $(SVN_REPO) \
get-orig-source/$(PACKAGE)-$(SRC_VERSION)
tar cJf $(TARBALL) -C get-orig-source \
+ --exclude=contrib \
$(PACKAGE)-$(SRC_VERSION)
@rm -rf get-orig-source
@echo " "$(TARBALL)" created; move it to the right destination to build the package"