summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2013-05-09 20:13:43 +0400
committerIgor Pashev <pashev.igor@gmail.com>2013-05-09 20:13:43 +0400
commit15938c13570ab2747bf59714902e944a79ee2bae (patch)
tree770a2b91f657eb2fb26c4ee17d73a0d674964523 /debian/rules
parentdb53e75a5a92175a86d05900c216a57cd318625d (diff)
downloadopen-axiom-debian-15938c13570ab2747bf59714902e944a79ee2bae.tar.gz
open-axiom (1.5.0~svn2823-1) UNRELEASED; urgency=low
* New upstream version. * Use xz compression for both source tarball and packages * Require g++ >= 4.7 for C++11 * Refreshed patches
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 3 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index dd7ee48..a0f165f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -22,15 +22,14 @@ PACKAGE := open-axiom
SVN_REPO := svn://svn.code.sf.net/p/open-axiom/code/trunk
SRC_VERSION := $(shell dpkg-parsechangelog | awk '/^Version:/ {sub(/-[^-]*/, "", $$2); print $$2}')
SVN_REVISION := $(shell echo $(SRC_VERSION) | sed -r 's,.+svn([0-9]+),\1,')
-TARBALL := $(PACKAGE)_$(SRC_VERSION).orig.tar.gz
+TARBALL := $(PACKAGE)_$(SRC_VERSION).orig.tar.xz
.PHONY: get-orig-source
get-orig-source:
rm -rf get-orig-source $(TARBALL)
mkdir get-orig-source
svn export -r $(SVN_REVISION) $(SVN_REPO) \
get-orig-source/$(PACKAGE)-$(SRC_VERSION)
- GZIP='--best --no-name' \
- tar czf $(TARBALL) -C get-orig-source \
+ tar cJf $(TARBALL) -C get-orig-source \
$(PACKAGE)-$(SRC_VERSION)
@rm -rf get-orig-source
@echo " "$(TARBALL)" created; move it to the right destination to build the package"
@@ -110,7 +109,7 @@ endif
dh_shlibdeps
dh_gencontrol
dh_md5sums
- dh_builddeb
+ dh_builddeb -- -Zxz
clean:
dh_testdir