summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2013-05-29 19:14:26 +0400
committerIgor Pashev <pashev.igor@gmail.com>2013-05-29 19:14:26 +0400
commite871ce3bb0887d9e105be58cd97e9902989305ed (patch)
treec4fd27c7e97ab4d81b007cc5b1580dd862c23f94
parent15938c13570ab2747bf59714902e944a79ee2bae (diff)
downloadopen-axiom-debian-e871ce3bb0887d9e105be58cd97e9902989305ed.tar.gz
New snapshot
fix building and packaging
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/install-dir.patch26
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules10
4 files changed, 14 insertions, 31 deletions
diff --git a/debian/changelog b/debian/changelog
index 023cffa..23b32bc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,11 +1,15 @@
-open-axiom (1.5.0~svn2823-1) UNRELEASED; urgency=low
+open-axiom (1.5.0~svn2965-1) UNRELEASED; urgency=low
* New upstream version.
* Use xz compression for both source tarball and packages
* Require g++ >= 4.7 for C++11
* Refreshed patches
+ * touch aclocal.m4 -r configure.ac to avoid rebuilding aclocal.m4 which
+ requires aclocal 1.13
+ * Do not patch configure.ac, but override variables in Makefiles (due to
+ automake 1.13 too)
- -- Igor Pashev <pashev.igor@gmail.com> Wed, 03 Apr 2013 16:56:48 +0400
+ -- Igor Pashev <pashev.igor@gmail.com> Wed, 29 May 2013 19:13:11 +0400
open-axiom (1.4.1+svn~2626-2) unstable; urgency=low
diff --git a/debian/patches/install-dir.patch b/debian/patches/install-dir.patch
deleted file mode 100644
index 3e0c4c4..0000000
--- a/debian/patches/install-dir.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: b/configure
-===================================================================
---- a/configure 2013-05-09 20:02:38.000000000 +0400
-+++ b/configure 2013-05-09 20:02:42.000000000 +0400
-@@ -3617,7 +3617,7 @@
-
-
-
--open_axiom_installdir=$libdir/open-axiom/$target/$PACKAGE_VERSION
-+open_axiom_installdir=$libdir/open-axiom
-
-
- if test $build != $target; then
-Index: b/configure.ac
-===================================================================
---- a/configure.ac 2013-05-09 20:02:38.000000000 +0400
-+++ b/configure.ac 2013-05-09 20:02:42.000000000 +0400
-@@ -54,7 +54,7 @@
- AC_CONFIG_SRCDIR(src/Makefile.in)
-
-
--open_axiom_installdir=$libdir/open-axiom/$target/$PACKAGE_VERSION
-+open_axiom_installdir=$libdir/open-axiom
- AC_SUBST(open_axiom_installdir)
-
- dnl For the moment, the OpenAxiom base source code is written
diff --git a/debian/patches/series b/debian/patches/series
index b38a365..893277e 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,2 @@
-install-dir.patch
no-missing-messages.patch
non-static-open-axiom-binary.patch
diff --git a/debian/rules b/debian/rules
index a0f165f..c4c83b0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,6 +17,7 @@ else
LISP := gcl
endif
+oa_libdir := /usr/lib/open-axiom
PACKAGE := open-axiom
SVN_REPO := svn://svn.code.sf.net/p/open-axiom/code/trunk
@@ -44,6 +45,8 @@ debian/open-axiom.1: build-stamp
# --disable-gcl is for included GCL:
configure-stamp:
dh_testdir
+ # aclocal.m4 is older than configure; rebuilding aclocal.m4 requires aclocal-1.13
+ touch aclocal.m4 -r configure.ac
dh_auto_configure -B $(BUILD) -- \
--with-lisp=$(LISP) \
--with-x \
@@ -56,7 +59,8 @@ build-arch: build-stamp
build-indep: build-stamp
build-stamp: configure-stamp
dh_testdir
- cd $(BUILD) && $(MAKE)
+ cd $(BUILD) && $(MAKE) \
+ open_axiom_installdir=$(oa_libdir)
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
cd $(BUILD) && $(MAKE) check
endif
@@ -67,7 +71,8 @@ install-stamp: build-stamp
dh_testdir
dh_testroot
dh_prep
- dh_auto_install -B $(BUILD)
+ dh_auto_install -B $(BUILD) -- \
+ oa_installdir=$(oa_libdir)
touch $@
binary: binary-arch binary-indep
@@ -76,6 +81,7 @@ binary-arch: install debian/open-axiom.1
ifeq ($(LISP), sbcl)
dh_install -p open-axiom usr/lib/open-axiom/lib/libopen-axiom-core.so
dh_install -p open-axiom usr/lib/open-axiom/algebra/*.fasl
+ dh_install -p open-axiom usr/lib/open-axiom/interp/*.fasl
# Remove shebangs and "compiled from ..." lines.
# This makes lintian happy and prevents disclosure
# of paths on build machine. E. g.: