summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2011-11-15 01:48:16 +0400
committerIgor Pashev <pashev.igor@gmail.com>2011-11-15 01:48:16 +0400
commita27c7ec378f5d33598468c7be1f3518f44b89486 (patch)
tree94a2d731ade5b231e18e1339e79a79721df1e905
parent87f783d32f9fd0082dbd15bf9563d483ece2e74d (diff)
downloadopen-axiom-debian-a27c7ec378f5d33598468c7be1f3518f44b89486.tar.gz
Fixed building with GCL
-rw-r--r--debian/README.lisps1
-rw-r--r--debian/changelog2
-rw-r--r--debian/open-axiom.install11
-rwxr-xr-xdebian/rules10
4 files changed, 19 insertions, 5 deletions
diff --git a/debian/README.lisps b/debian/README.lisps
index b9e5ef7..a8e4fb5 100644
--- a/debian/README.lisps
+++ b/debian/README.lisps
@@ -8,4 +8,5 @@ i386, amd64, kfreebsd-amd64.
On other arch GCL should be used.
To build with GCL libncurses-dev and libreadline-dev are required.
+If changing lisp remember to edit debian/control, debian/rules and this file.
diff --git a/debian/changelog b/debian/changelog
index 1447285..0d0ebc7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-open-axiom (1.4.1+svn~2466-1) unstable; urgency=low
+open-axiom (1.4.1+svn~2470-1) unstable; urgency=low
* New upstream version
* Include directory 'contrib' in sources
diff --git a/debian/open-axiom.install b/debian/open-axiom.install
index 0af2e42..a4ee7cf 100644
--- a/debian/open-axiom.install
+++ b/debian/open-axiom.install
@@ -1,6 +1,11 @@
usr/bin/open-axiom
usr/lib/open-axiom/lib/ex2ht
-usr/lib/open-axiom/algebra/*.fasl
+
+# *.o for GCL
+# *.fasl for SBCL
+# it's a kind of hack
+usr/lib/open-axiom/algebra/*.{o,fasl}
+
usr/lib/open-axiom/lib/session
usr/lib/open-axiom/lib/spadbuf
usr/lib/open-axiom/lib/spadclient
@@ -19,7 +24,9 @@ usr/lib/open-axiom/bin/clef
usr/lib/open-axiom/bin/asq
usr/lib/open-axiom/bin/AXIOMsys
-usr/lib/open-axiom/lib/libopen-axiom-core.so
+# GCL does not use shared libs
+# for SBCL we put this lib in debian/rules
+#usr/lib/open-axiom/lib/libopen-axiom-core.so
debian/open-axiom.xpm /usr/share/pixmaps/
debian/open-axiom.desktop /usr/share/applications/
diff --git a/debian/rules b/debian/rules
index a90b471..d7cfc65 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,8 +24,8 @@ get-orig-source:
GZIP='--best --no-name' \
tar czf $(TARBALL) -C get-orig-source \
$(PACKAGE)-$(SRC_VERSION).orig
- rm -rf get-orig-source
- echo " "$(TARBALL)" created; move it to the right destination to build the package"
+ @rm -rf get-orig-source
+ @echo " "$(TARBALL)" created; move it to the right destination to build the package"
debian/open-axiom.1:
help2man --no-info \
@@ -40,10 +40,13 @@ BUILD = $(CURDIR)/build-tree
LDFLAGS = -Wl,--as-needed
+
+# --disable-gcl is for included GCL:
override_dh_auto_configure:
dh_auto_configure -B $(BUILD) -- \
--with-lisp=$(LISP) \
--with-x \
+ --disable-gcl \
LDFLAGS="$(LDFLAGS)"
# Remove shebangs and "compiled from ..." lines.
@@ -63,6 +66,9 @@ override_dh_auto_clean:
rm -rf $(BUILD)
override_dh_install:
+ifeq ($(LISP), sbcl)
+ dh_install -p open-axiom usr/lib/open-axiom/lib/libopen-axiom-core.so
+endif
dh_install --list-missing
override_dh_installman: debian/open-axiom.1