summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules44
1 files changed, 44 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..4344e23
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,44 @@
+#!/usr/bin/make -f
+# See debhelper(7) (uncomment to enable)
+# output every command that modifies files on the build system.
+#export DH_VERBOSE = 1
+
+# see FEATURE AREAS in dpkg-buildflags(1)
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+# see ENVIRONMENT in dpkg-buildflags(1)
+# package maintainers to append CFLAGS
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+# package maintainers to append LDFLAGS
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+%:
+ dh $@
+
+# trick to add -g to CFLAGS
+override_dh_auto_configure:
+ # --enable-debug is a gnucobol-specific option which permits to add -g
+ # but disable optimisations by default
+ #maybe needed again: CFLAGS='-g -O2 -finline-functions -U_FORTIFY_SOURCE' dh_auto_configure -- --enable-debug
+ CFLAGS='-g -O2 -finline-functions -D_FORTIFY_SOURCE=2' dh_auto_configure -- --enable-debug
+
+# Clean generated files
+override_dh_clean:
+ #not needed anymore: rm -f doc/gnucobol.pdf bin/cobcrun.1 cobc/cobc.1 doc/gnucobol.info
+ dh_clean
+
+# force build PDF
+override_dh_auto_build:
+ dh_auto_build
+ $(MAKE) -C doc gnucobol.pdf
+
+# disable auto_test
+# because one of them depends on an external service
+# http://www.itl.nist.gov/div897/ctg/suites/newcob.val.Z
+override_dh_auto_test:
+
+override_dh_auto_install:
+ dh_auto_install
+ # remove some uneeded files
+ rm -f debian/tmp/usr/lib/*/gnucobol/CBL_OC_DUMP.so
+ rm -f debian/tmp/usr/lib/*/libcob.la