summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/honor-sysconfdir.diff10
-rw-r--r--debian/patches/man-pages.patch22
-rw-r--r--debian/patches/readline-libs.patch31
-rw-r--r--debian/patches/remove-AM_GNU_GETTEXT_VERSION.patch10
-rw-r--r--debian/patches/replace-ac-check-file.patch25
-rw-r--r--debian/patches/series3
6 files changed, 59 insertions, 42 deletions
diff --git a/debian/patches/honor-sysconfdir.diff b/debian/patches/honor-sysconfdir.diff
index ca8ecce..d3d59db 100644
--- a/debian/patches/honor-sysconfdir.diff
+++ b/debian/patches/honor-sysconfdir.diff
@@ -2,12 +2,12 @@ Description: configure script read the sysconfdir option
Author: Ludwin Janvier <lud.janvier@gmail.com>
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
-Index: gnucobol-4.0-early-20200606/configure.ac
+Index: gnucobol4-debian/configure.ac
===================================================================
---- gnucobol-4.0-early-20200606.orig/configure.ac
-+++ gnucobol-4.0-early-20200606/configure.ac
-@@ -1931,6 +1931,10 @@ elif test "$COB_USES_GCC" = "yes" && tes
- fi
+--- gnucobol4-debian.orig/configure.ac
++++ gnucobol4-debian/configure.ac
+@@ -2453,6 +2453,10 @@ elif test "$COB_USES_GCC" = "yes" && tes
+ CFLAGS="$CFLAGS -fsigned-char -Wall -Wwrite-strings -Wmissing-prototypes -Wno-format-y2k"
fi
+if test -n "$sysconfdir"; then
diff --git a/debian/patches/man-pages.patch b/debian/patches/man-pages.patch
index 54b85fb..e984f6b 100644
--- a/debian/patches/man-pages.patch
+++ b/debian/patches/man-pages.patch
@@ -1,22 +1,22 @@
Description: add some fields to the man page
-Index: gnucobol-4.0-early-20200606/bin/Makefile.am
+Index: gnucobol4-debian/bin/Makefile.am
===================================================================
---- gnucobol-4.0-early-20200606.orig/bin/Makefile.am
-+++ gnucobol-4.0-early-20200606/bin/Makefile.am
-@@ -41,7 +41,7 @@ CODE_COVERAGE_LCOV_OPTIONS = --no-exter
- MAINTAINERCLEANFILES = cobcrun.1
+--- gnucobol4-debian.orig/bin/Makefile.am
++++ gnucobol4-debian/bin/Makefile.am
+@@ -50,7 +50,7 @@ MAINTAINERCLEANFILES = cobcrun.1
- HELPSOURCES = cobcrun.c $(top_srcdir)/configure.ac
+ HELPSOURCES_COBCRUN = cobcrun.c $(top_srcdir)/configure.ac
+ HELPSOURCES_COBCONFIG = cob-config.in $(top_srcdir)/configure.ac
-HELP2MAN_OPTS = --info-page=$(PACKAGE)
+HELP2MAN_OPTS = --section=1 --name="GnuCOBOL module loader" --info-page=$(PACKAGE)
if MAKE_HAS_PREREQ_ONLY
- cobcrun.1: $(HELPSOURCES) | $(COBCRUN)
-Index: gnucobol-4.0-early-20200606/cobc/Makefile.am
+ cobcrun.1: $(HELPSOURCES_COBCRUN) | $(COBCRUN)
+Index: gnucobol4-debian/cobc/Makefile.am
===================================================================
---- gnucobol-4.0-early-20200606.orig/cobc/Makefile.am
-+++ gnucobol-4.0-early-20200606/cobc/Makefile.am
-@@ -49,7 +49,7 @@ CODE_COVERAGE_BRANCH_COVERAGE=1
+--- gnucobol4-debian.orig/cobc/Makefile.am
++++ gnucobol4-debian/cobc/Makefile.am
+@@ -54,7 +54,7 @@ CODE_COVERAGE_BRANCH_COVERAGE=1
CODE_COVERAGE_LCOV_OPTIONS = --no-external
HELPSOURCES = help.c config.def flag.def warning.def $(top_srcdir)/configure.ac
diff --git a/debian/patches/readline-libs.patch b/debian/patches/readline-libs.patch
new file mode 100644
index 0000000..1792f59
--- /dev/null
+++ b/debian/patches/readline-libs.patch
@@ -0,0 +1,31 @@
+--- gnucobol4-4.0~2022.11.11.svn.4819.orig/bin/Makefile.am
++++ gnucobol4-4.0~2022.11.11.svn.4819/bin/Makefile.am
+@@ -35,7 +35,7 @@ AM_CPPFLAGS = -I$(top_srcdir) -I$(top_bu
+ AM_CFLAGS = $(CODE_COVERAGE_CFLAGS)
+ cobcrun_LDADD = $(COMMON_LIBS)
+ gcdiff_LDADD = $(COMMON_LIBS)
+-cobfile_LDADD =$(COMMON_LIBS)
++cobfile_LDADD = $(COMMON_LIBS) $(READLINE_LIBS)
+
+ # Add rules for code-coverage testing, as provided AX_CODE_COVERAGE
+ include $(top_srcdir)/aminclude_static.am
+--- gnucobol4-4.0~2022.11.11.svn.4819.orig/configure.ac
++++ gnucobol4-4.0~2022.11.11.svn.4819/configure.ac
+@@ -857,7 +857,8 @@ AC_CHECK_LIB([$USE_MATH], [__gmp_get_mem
+
+ AC_CHECK_LIB([readline], [readline],
+ [AC_DEFINE([HAVE_READLINE], [1])
+- LIBCOB_LIBS="$LIBCOB_LIBS -lreadline" ], [], [])
++ LIBCOB_LIBS="$LIBCOB_LIBS -lreadline"
++ READLINE_LIBS="-lreadline" ], [], [])
+
+ dnl
+ dnl Configure options part II (needing compilation)
+@@ -2646,6 +2647,7 @@ AC_SUBST([QUOTE_INCLUDE_FLAG])
+ AC_SUBST([COBC_CPPFLAGS])
+ AC_SUBST([PROGRAMS_LIBS])
+ AC_SUBST([LIBCOB_LIBS])
++AC_SUBST([READLINE_LIBS])
+ AC_SUBST([LIBCOB_CPPFLAGS])
+ AC_SUBST([LIBCOB_VER])
+ AC_SUBST([CISAM_LIBS])
diff --git a/debian/patches/remove-AM_GNU_GETTEXT_VERSION.patch b/debian/patches/remove-AM_GNU_GETTEXT_VERSION.patch
new file mode 100644
index 0000000..ad4f940
--- /dev/null
+++ b/debian/patches/remove-AM_GNU_GETTEXT_VERSION.patch
@@ -0,0 +1,10 @@
+--- gnucobol4-4.0~2022.11.11.svn.4819.orig/configure.ac
++++ gnucobol4-4.0~2022.11.11.svn.4819/configure.ac
+@@ -2100,7 +2100,6 @@ dnl AC_MSG_RESULT([yes])],
+ dnl [AC_MSG_RESULT([no])])
+
+ AM_GNU_GETTEXT([external])
+-AM_GNU_GETTEXT_VERSION([0.19.8])
+ if test "x$LTLIBINTL" != x; then
+ if test "x$PROGRAMS_LIBS" != x; then
+ PROGRAMS_LIBS="$PROGRAMS_LIBS $LTLIBINTL"
diff --git a/debian/patches/replace-ac-check-file.patch b/debian/patches/replace-ac-check-file.patch
deleted file mode 100644
index 4ce7976..0000000
--- a/debian/patches/replace-ac-check-file.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Description: gnucobol3 fails to cross build from source, because it abuses
- AC_CHECK_FILE. The macro is meant to check for files on the host system,
- but it is used to check for files inside the build tree.
-Author: Helmut Grohne <helmut@subdivi.de>
---- gnucobol4-4.0~early~20200606.orig/configure.ac
-+++ gnucobol4-4.0~early~20200606/configure.ac
-@@ -590,7 +590,7 @@
- AC_MSG_NOTICE([Checks for local cJSON ...])
- curr_libs="$LIBS"; curr_cppflags="$CPPFLAGS"
- with_cjson_local=no
-- AC_CHECK_FILE([./libcob/cJSON.c],
-+ AS_IF([test -e ./libcob/cJSON.c],
- [AC_MSG_CHECKING([if linking of ./libcob/cJSON.c works])
- CPPFLAGS="$curr_cppflags -I./libcob"
- AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include "cJSON.c"]],
-@@ -601,7 +601,7 @@
- )]
- )
- if test "$with_cjson_local" = "no"; then
-- AC_CHECK_FILE([$srcdir/libcob/cJSON.c],
-+ AS_IF([test -e "$srcdir/libcob/cJSON.c"],
- [AC_MSG_CHECKING([if linking of $srcdir/libcob/cJSON.c works])
- CPPFLAGS="$curr_cppflags -I$srcdir/libcob"
- AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include "cJSON.c"]],
-
diff --git a/debian/patches/series b/debian/patches/series
index cfe77e0..86093d3 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
honor-sysconfdir.diff
man-pages.patch
-replace-ac-check-file.patch
+readline-libs.patch
+remove-AM_GNU_GETTEXT_VERSION.patch