summaryrefslogtreecommitdiff
path: root/debian/patches/replace-ac-check-file.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/replace-ac-check-file.patch')
-rw-r--r--debian/patches/replace-ac-check-file.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/patches/replace-ac-check-file.patch b/debian/patches/replace-ac-check-file.patch
new file mode 100644
index 0000000..4ce7976
--- /dev/null
+++ b/debian/patches/replace-ac-check-file.patch
@@ -0,0 +1,25 @@
+Description: gnucobol3 fails to cross build from source, because it abuses
+ AC_CHECK_FILE. The macro is meant to check for files on the host system,
+ but it is used to check for files inside the build tree.
+Author: Helmut Grohne <helmut@subdivi.de>
+--- gnucobol4-4.0~early~20200606.orig/configure.ac
++++ gnucobol4-4.0~early~20200606/configure.ac
+@@ -590,7 +590,7 @@
+ AC_MSG_NOTICE([Checks for local cJSON ...])
+ curr_libs="$LIBS"; curr_cppflags="$CPPFLAGS"
+ with_cjson_local=no
+- AC_CHECK_FILE([./libcob/cJSON.c],
++ AS_IF([test -e ./libcob/cJSON.c],
+ [AC_MSG_CHECKING([if linking of ./libcob/cJSON.c works])
+ CPPFLAGS="$curr_cppflags -I./libcob"
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include "cJSON.c"]],
+@@ -601,7 +601,7 @@
+ )]
+ )
+ if test "$with_cjson_local" = "no"; then
+- AC_CHECK_FILE([$srcdir/libcob/cJSON.c],
++ AS_IF([test -e "$srcdir/libcob/cJSON.c"],
+ [AC_MSG_CHECKING([if linking of $srcdir/libcob/cJSON.c works])
+ CPPFLAGS="$curr_cppflags -I$srcdir/libcob"
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include "cJSON.c"]],
+