aboutsummaryrefslogtreecommitdiff
path: root/src/rt/Makefile.am
diff options
context:
space:
mode:
authordos-reis <gdr@axiomatics.org>2013-06-28 05:02:14 +0000
committerdos-reis <gdr@axiomatics.org>2013-06-28 05:02:14 +0000
commit50ec7502934e4632348f4c3c8e060181f199dfc8 (patch)
treecd60fa76d27d654344f093a326222ff21685701b /src/rt/Makefile.am
parentb52f0164b18f06db386d527be26e3a11deb1ab7d (diff)
downloadopen-axiom-50ec7502934e4632348f4c3c8e060181f199dfc8.tar.gz
Add src/rt for core runtime support.
Diffstat (limited to 'src/rt/Makefile.am')
-rw-r--r--src/rt/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/src/rt/Makefile.am b/src/rt/Makefile.am
new file mode 100644
index 00000000..c7f32b7d
--- /dev/null
+++ b/src/rt/Makefile.am
@@ -0,0 +1,44 @@
+# Copyright (C) 2013, Gabriel Dos Reis.
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# - Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# - Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in
+# the documentation and/or other materials provided with the
+# distribution.
+#
+# - Neither the name of OpenAxiom. nor the names of its contributors
+# may be used to endorse or promote products derived from this
+# software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS
+# IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
+# TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
+# PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER
+# OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
+# EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
+# PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+# LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+
+noinst_LIBRARIES = libruntime.a
+
+libruntime_a_SOURCES = vm.cc Lisp.cc Database.cc
+
+oa_target_incdir = $(top_builddir)/$(target)/include
+
+libruntime_a_CPPFLAGS = -I$(top_srcdir)/src/include -I$(oa_target_incdir)
+
+
+.PHONY: all-rt
+all-rt: all-am
+