aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordos-reis <gdr@axiomatics.org>2010-05-07 19:41:44 +0000
committerdos-reis <gdr@axiomatics.org>2010-05-07 19:41:44 +0000
commit75e606946370e97837e697e5f5070ddff4627952 (patch)
tree6a51f09fc2c32104ddb7eb328cc2270045f0b5bc /configure.ac
parentc9c4d89aa7cc261a19ac29c7d74a43f1369f1773 (diff)
downloadopen-axiom-75e606946370e97837e697e5f5070ddff4627952.tar.gz
* configure.ac.pamphlet: Add new option: --enable-int-file-retention.
src/ * lisp/core.lisp.in ($FilesToRetain): New. Export. * lisp/Makefile.in: Tidy. * boot/translator.boot (retainFile?): New. (compileBootHandler): Use it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a1ec4cab..826456bf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -358,6 +358,16 @@ if test -z $axiom_fasl_type; then
fi
AC_SUBST(axiom_fasl_type)
+## Occaionally, we may want to keep intermediary files.
+oa_keep_files=
+AC_ARG_ENABLE([keep-files],
+ [ --enable-keep-files=<kind> keep intermediary files],
+ [case $enableval in
+ yes|no|all) oa_keep_files=$enableval ;;
+ *) AC_MSG_ERROR([erroneous value for --enable-keep-files]) ;;
+ esac])
+AC_SUBST(oa_keep_files)
+
## Does it make sense to pretend that we support multithreading?
oa_enable_threads=no
AC_ARG_ENABLE([threads], [ --enable-threads turn on threads support],