aboutsummaryrefslogtreecommitdiff
path: root/modules/pkgs/check_mdstat
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2018-12-11 18:10:48 +0300
committerIgor Pashev <pashev.igor@gmail.com>2018-12-11 18:10:48 +0300
commit8b0968b2054d3bb8d90b5ac056727f7c2ebeaed3 (patch)
treed03b70f693463fc836a8dbe4240424d2547530c8 /modules/pkgs/check_mdstat
parentc4273035cf5876e3ba8ed2c6b492d31c2de290ee (diff)
downloadnixsap-8b0968b2054d3bb8d90b5ac056727f7c2ebeaed3.tar.gz
(* HUGE *) Use nixpkgs overlays
Diffstat (limited to 'modules/pkgs/check_mdstat')
-rwxr-xr-xmodules/pkgs/check_mdstat/check_mdstat50
-rw-r--r--modules/pkgs/check_mdstat/default.nix26
2 files changed, 0 insertions, 76 deletions
diff --git a/modules/pkgs/check_mdstat/check_mdstat b/modules/pkgs/check_mdstat/check_mdstat
deleted file mode 100755
index 32fc168..0000000
--- a/modules/pkgs/check_mdstat/check_mdstat
+++ /dev/null
@@ -1,50 +0,0 @@
-#!/usr/bin/env bash
-
-stat=/proc/mdstat
-
-if [ ! -e "$stat" ]; then
- echo "WARNING: $stat does not exist"
- exit 1
-fi
-
-if [ ! -r "$stat" ]; then
- echo "WARNING: cannot read $stat"
- exit 1
-fi
-
-count=$(grep ^md -c "$stat")
-
-if [ "$count" -eq 0 ]; then
- echo 'WARNING: no arrays found.'
- exit 1
-elif [ "$count" -eq 1 ]; then
- out="Linux Software RAID: $count array"
-else
- out="Linux Software RAID: $count arrays"
-fi
-
-degrated=$(grep -c '\[.*_.*\]' "$stat")
-recovering=$(awk '/recovery/ {print $4}' "$stat")
-resyncing=$(awk '/resync/ {print $4}' "$stat")
-
-if [ -n "$recovering" ]; then
- out="$out, recovering: $recovering"
-elif [ -n "$resyncing" ]; then
- out="$out, resyncing: $resyncing"
-elif [ "$degrated" -gt 0 ]; then
- out="$out, degrated: $degrated"
-fi
-
-if [ "$degrated" -gt 0 ]; then
- echo "CRITICAL: $out."
- exit 2
-fi
-
-if [ -n "$recovering$resyncing" ]; then
- echo "WARNING: $out."
- exit 1
-fi
-
-echo "OK: $out."
-exit 0
-
diff --git a/modules/pkgs/check_mdstat/default.nix b/modules/pkgs/check_mdstat/default.nix
deleted file mode 100644
index 5e645fd..0000000
--- a/modules/pkgs/check_mdstat/default.nix
+++ /dev/null
@@ -1,26 +0,0 @@
-{ stdenv, gawk, gnugrep }:
-
-stdenv.mkDerivation {
- name = "check_mdstat";
- src = ./check_mdstat;
- outputs = [ "out" "conf" ];
- unpackPhase = ":";
- installPhase = ''
- mkdir -p $out/bin
-
- cp "$src" $out/bin/check_mdstat
-
- substituteInPlace "$out/bin/"* \
- --replace awk '${gawk}/bin/awk' \
- --replace grep '${gnugrep}/bin/grep'
-
- chmod +x "$out/bin/"*
-
- cat <<CONF > $conf
- object CheckCommand "mdstat" {
- import "plugin-check-command"
- command = [ "$out/bin/check_mdstat" ]
- }
- CONF
- '';
-}