summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c2f065e..ef44f90 100644
--- a/configure.in
+++ b/configure.in
@@ -103,6 +103,8 @@ if test "$make_cv_file_timestamp_hi_res" = yes; then
fi
fi
+# Check for DOS-style pathnames.
+pds_AC_DOS_PATHS
# See if we have a standard version of gettimeofday(). Since actual
# implementations can differ, just make sure we have the most common
@@ -192,6 +194,13 @@ fi
AC_MSG_RESULT($make_cv_union_wait)
+# If we're building on Windows/DOS/OS/2, add some support for DOS drive specs.
+if test "$PATH_SEPARATOR" = ';'; then
+ AC_DEFINE(HAVE_DOS_PATHS, 1,
+ [Define this if your system requires backslashes or drive specs in pathnames.])
+fi
+
+
# See if the user wants to use pmake's "customs" distributed build capability
AC_SUBST(REMOTE) REMOTE=stub