summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index edb8ad6..55d14e6 100644
--- a/configure.in
+++ b/configure.in
@@ -55,14 +55,19 @@ pid = waitpid (-1, &status, 0);
],
AC_DEFINE(HAVE_UNION_WAIT))
-AC_COMPILE_CHECK(sys_siglist declaration in signal.h,
- [#include <signal.h>], [char *msg = *(sys_siglist + 1);],
+AC_COMPILE_CHECK(sys_siglist declaration in signal.h or unistd.h,
+ [#include <signal.h>
+/* NetBSD declares sys_siglist in <unistd.h>. */
+#ifdef HAVE_UNISTD_H
+#include <unistd.h>
+#endif], [char *msg = *(sys_siglist + 1);],
AC_DEFINE(SYS_SIGLIST_DECLARED))
# The presence of the following is not meant to imply
# that make necessarily works on those systems.
AC_DYNIX_SEQ
AC_XENIX_DIR
+AC_IRIX_SUN
AC_SUBST(REMOTE) REMOTE=stub
AC_WITH(customs, [REMOTE=cstms