summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2005-02-26 01:41:48 +0000
committerPaul Smith <psmith@gnu.org>2005-02-26 01:41:48 +0000
commit9d153cc1b1e467cd6245755c32f78efbd62142c2 (patch)
tree229919252d0b4a25e1e5c00d80ab744fbe5b5c81 /configure.in
parent6d995b036e714ea3d61112ebc582b0671cc36e77 (diff)
downloadgunmake-9d153cc1b1e467cd6245755c32f78efbd62142c2.tar.gz
Add configure operations to support MINGW on Windows.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a8c35ec..7e4d545 100644
--- a/configure.in
+++ b/configure.in
@@ -235,6 +235,15 @@ AC_ARG_WITH(customs,
# Tell automake about this, so it can include the right .c files.
AM_CONDITIONAL(USE_CUSTOMS, test "$use_customs" = true)
+# See if the user asked to handle case insensitive file systems.
+
+AH_TEMPLATE(HAVE_CASE_INSENSITIVE_FS, [Use case insensitive file names])
+AC_ARG_ENABLE(case-insensitive-file-system,
+ AC_HELP_STRING([--enable-case-insensitive-file-system],
+ [enable case insensitive file system support]),
+ case_insensitive_fs="yes" AC_DEFINE(HAVE_CASE_INSENSITIVE_FS),
+ case_insensitive_fs="no")
+
# See if we can handle the job server feature, and if the user wants it.
AC_ARG_ENABLE(job-server,
@@ -331,6 +340,18 @@ AC_DEFINE_UNQUOTED(MAKE_HOST,"$host",[Build host information.])
MAKE_HOST="$host"
AC_SUBST(MAKE_HOST)
+w32_target_env=no
+AM_CONDITIONAL(WINDOWSENV, false)
+
+case "$host" in
+ *-*-mingw32)
+ AM_CONDITIONAL(WINDOWSENV, true)
+ w32_target_env=yes
+ AC_DEFINE([WINDOWS32], [1], [Use platform specific coding])
+ AC_DEFINE([HAVE_DOS_PATHS], [1], [Use platform specific coding])
+ ;;
+esac
+
# Include the Maintainer's Makefile section, if it's here.
MAINT_MAKEFILE=/dev/null
@@ -391,6 +412,11 @@ esac
# Specify what files are to be created.
AC_CONFIG_FILES(Makefile glob/Makefile po/Makefile.in config/Makefile doc/Makefile)
+# Only process if target is MS-Windows
+if test "$w32_target_env" == yes; then
+ AC_CONFIG_FILES(w32/Makefile)
+fi
+
# OK, do it!
AC_OUTPUT