summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2003-01-30 05:22:52 +0000
committerPaul Smith <psmith@gnu.org>2003-01-30 05:22:52 +0000
commitd33ff301454fa1db9919674dbc2a37309bbd529f (patch)
treeb843b352a445c03c8d1f4c2265334ea0e83de046 /configure.in
parentd15a484098a52e0784933ba03a98445fdc86ea3f (diff)
downloadgunmake-d33ff301454fa1db9919674dbc2a37309bbd529f.tar.gz
Portability fix for glob.h building in FreeBSD ports system.
Implement a fix for bug # 2169: too many OSs, even major OSs like Solaris, don't properly implement SA_RESTART: important system calls like stat() can still fail when SA_RESTART is set. So, forget the BROKEN_RESTART config check and get rid of atomic_stat() and atomic_readdir(), and implement permanent wrappers for EINTR checking on various system calls (stat(), fstat(), opendir(), and readdir() so far).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 0 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index 8df2e27..befba08 100644
--- a/configure.in
+++ b/configure.in
@@ -294,21 +294,6 @@ make_cv_sys_gnu_glob=no])])
# Tell automake about this, so it can build the right .c files.
AM_CONDITIONAL(USE_LOCAL_GLOB, test "$make_cv_sys_gnu_glob" = no)
-# PTX systems have a broken implementation of SA_RESTART. I know of
-# no way to test for this behavior, so I'll just test for PTX
-
-case "$host" in
- i386-sequent-sysv4)
- AC_DEFINE(HAVE_BROKEN_RESTART, 1, [This system has SA_RESTART, but it doesn't work properly.])
- echo ""
- echo "WARNING: The SA_RESTART sigaction() flag does not work on PTX."
- echo " This causes 'make -j' to fail at random times."
- echo " I am installing a workaround, which is mostly but not 100%"
- echo " effective. If you see random failures during 'make -j'"
- echo " you should either contact the bug list, or not use -j."
- echo "" ;;
-esac
-
# Let the makefile know what our build host is
AC_DEFINE_UNQUOTED(MAKE_HOST,"$host",[Build host information.])