summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2005-02-16 05:03:42 +0000
committerPaul Smith <psmith@gnu.org>2005-02-16 05:03:42 +0000
commite8ca9b8eb1caaa43703f6ce505af78c6e7b9e60b (patch)
tree06c563611aef3116a6f2de2844082f4609982039 /configure.in
parentc90f47e8320b41e3a5bfeb654543d9474f763e5d (diff)
downloadgunmake-e8ca9b8eb1caaa43703f6ce505af78c6e7b9e60b.tar.gz
Add a patch from Paul Eggert that's been lying around in my directory for
a long time, disabling stack size limits where possible. Update version to beta2.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 4bad3e2..a8c35ec 100644
--- a/configure.in
+++ b/configure.in
@@ -1,6 +1,6 @@
# Process this file with autoconf to produce a configure script.
-AC_INIT([GNU make],[3.81beta1],[bug-make@gnu.org])
+AC_INIT([GNU make],[3.81beta2],[bug-make@gnu.org])
AC_PREREQ(2.59)
AC_REVISION([[$Id$]])
@@ -50,7 +50,7 @@ AC_HEADER_DIRENT
AC_HEADER_STAT
AC_HEADER_TIME
AC_CHECK_HEADERS(stdlib.h locale.h unistd.h limits.h fcntl.h string.h \
- memory.h sys/param.h sys/time.h sys/timeb.h)
+ memory.h sys/param.h sys/resource.h sys/time.h sys/timeb.h)
# Set a flag if we have an ANSI C compiler
if test "$ac_cv_prog_cc_stdc" != no; then
@@ -136,7 +136,7 @@ fi
AC_CHECK_FUNCS( memcpy memmove strchr strdup mkstemp mktemp fdopen \
bsd_signal dup2 getcwd realpath sigsetmask sigaction \
getgroups seteuid setegid setlinebuf setreuid setregid \
- setvbuf pipe strerror strsignal)
+ getrlimit setrlimit setvbuf pipe strerror strsignal)
AC_FUNC_SETVBUF_REVERSED