summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2011-11-15 21:12:53 +0000
committerPaul Smith <psmith@gnu.org>2011-11-15 21:12:53 +0000
commitdc2a6ceb81730c25c0beec1f13994b9710767ee1 (patch)
treed8ffe41c5bb5af3a5544af0a8a0bdfc36eb2fd01 /configure.in
parent4f47fbf953faae5d38bdc4e709aa8872e3914418 (diff)
downloadgunmake-dc2a6ceb81730c25c0beec1f13994b9710767ee1.tar.gz
Enable jobserver on W32 when using configure.
Some W32 cleanups: see Savannah bug #34830 Forgot to modify the config.h.W32.template file for jobserver support.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 11 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index a1e720b..31c528d 100644
--- a/configure.in
+++ b/configure.in
@@ -301,18 +301,21 @@ if test "$make_cv_sa_restart" != no; then
[Define to 1 if <signal.h> defines the SA_RESTART constant.])
fi
-# enable make_cv_sa_restart for OS/2 so that the jobserver will be enabled,
-# but do it after HAVE_SA_RESTART has been defined.
-case "$host_os" in
- os2*) make_cv_sa_restart=yes ;;
+# Only allow jobserver on systems that support it
+case "/$ac_cv_func_pipe/$ac_cv_func_sigaction/$make_cv_sa_restart/$has_wait_nohang/" in
+ */no/*) make_cv_job_server=no ;;
esac
-case "$ac_cv_func_pipe/$ac_cv_func_sigaction/$make_cv_sa_restart/$has_wait_nohang/$make_cv_job_server" in
- yes/yes/yes/yes/yes)
- AC_DEFINE(MAKE_JOBSERVER, 1,
- [Define to 1 to enable job server support in GNU make.]);;
+# Also supported on OS2 and W32
+case "$host_os" in
+ os2*|mingw32) make_cv_sa_restart=yes ;;
esac
+if test "$make_cv_job_server" != no; then
+ AC_DEFINE(MAKE_JOBSERVER, 1,
+ [Define to 1 to enable job server support in GNU make.])
+fi
+
# if we have both lstat() and readlink() then we can support symlink
# timechecks.
case "$ac_cv_func_lstat/$ac_cv_func_readlink" in