summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>1999-02-22 07:23:30 +0000
committerPaul Smith <psmith@gnu.org>1999-02-22 07:23:30 +0000
commita66668aabccfbae3e1f22eaeb897b9c7a1e02733 (patch)
treefd4454775a6dcb2d0222f3e65c04f2011547b4ea /configure.in
parent84f38c9c6f56c7056a1d1a5abf9151bf15760151 (diff)
downloadgunmake-a66668aabccfbae3e1f22eaeb897b9c7a1e02733.tar.gz
* New feature: .LIBPATTERNS controls the way -lfoo dependencies are expanded.
* A few tweaks to the system glob test, after trying it on a system where it's true. * Installed patches to archive handling for AIX 4.3 big archives. * Fix a memory stomp in target-specific variables. * Fix a memory leak in foreach functions.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 7 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index be51781..bc72d7d 100644
--- a/configure.in
+++ b/configure.in
@@ -154,17 +154,20 @@ rm -f s.conftest conftoast
AC_MSG_CHECKING(if system libc has GNU glob)
AC_CACHE_VAL(make_cv_sys_gnu_glob, [
AC_TRY_CPP([
+#include <features.h>
#include <glob.h>
#include <fnmatch.h>
#define GLOB_INTERFACE_VERSION 1
-#if !defined _LIBC && defined __GNU_LIBRARY__ && __GNU_LIBRARY__ > 1
+#if defined _LIBC || !defined __GNU_LIBRARY__ || __GNU_LIBRARY__ <= 1
+# error no gnu glob
+#else
# include <gnu-versions.h>
-# if _GNU_GLOB_INTERFACE_VERSION == GLOB_INTERFACE_VERSION
-# error have gnu glob
+# if _GNU_GLOB_INTERFACE_VERSION != GLOB_INTERFACE_VERSION
+# error no gnu glob
# endif
#endif
- ], make_cv_sys_gnu_glob=no, make_cv_sys_gnu_glob=yes)])
+ ], make_cv_sys_gnu_glob=yes, make_cv_sys_gnu_glob=no)])
case "$make_cv_sys_gnu_glob" in
yes) AC_MSG_RESULT(yes) ;;
no) AC_MSG_RESULT([no; using local copy])