summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>1999-08-31 17:02:31 +0000
committerPaul Smith <psmith@gnu.org>1999-08-31 17:02:31 +0000
commit27255c5b51c25f0256b8432446fca403c92e0a06 (patch)
tree2a267a037fb2339f62e8deb21a1eb7cc0acb66e3 /configure.in
parentb134da55059775759b6e2d1ab8d6425033c3834a (diff)
downloadgunmake-27255c5b51c25f0256b8432446fca403c92e0a06.tar.gz
* Large file support for AIX, HP-UX, and IRIX.
* W32 support for Cygnus Cygwin shell (bash).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 9cc0b05..00958cd 100644
--- a/configure.in
+++ b/configure.in
@@ -3,11 +3,12 @@ AC_REVISION([$Id$])
AC_PREREQ(2.13)dnl dnl Minimum Autoconf version required.
AC_INIT(vpath.c)dnl dnl A distinctive file to look for in srcdir.
-AM_INIT_AUTOMAKE(make, 3.77.94)
+AM_INIT_AUTOMAKE(make, 3.77.95)
AM_CONFIG_HEADER(config.h)
dnl Regular configure stuff
+AC_CANONICAL_HOST
AC_PROG_MAKE_SET
AC_PROG_CC
AC_PROG_INSTALL
@@ -21,7 +22,7 @@ AC_MINIX
dnl This test must come as early as possible after the compiler configuration
dnl tests, because the choice of the file model can (in principle) affect
dnl whether functions and headers are available, whether they work, etc.
-AC_LFS
+AC_SYS_LARGEFILE
AC_HEADER_STDC
AC_HEADER_DIRENT
@@ -31,6 +32,7 @@ AC_TYPE_SIGNAL
AC_CHECK_HEADERS(stdlib.h unistd.h limits.h sys/param.h fcntl.h string.h \
memory.h sys/timeb.h)
AC_PROG_CC_C_O
+AM_PROG_CC_STDC
AC_C_CONST dnl getopt needs this.
AC_HEADER_STAT
@@ -66,9 +68,10 @@ AC_FUNC_VPRINTF
AC_FUNC_STRCOLL
AC_FUNC_CLOSEDIR_VOID
AC_FUNC_SETVBUF_REVERSED
-AC_FUNC_GETLOADAVG
AC_FUNC_SELECT
-AC_CHECK_LIB(kstat, kstat_open)
+
+AC_CHECK_LIB(kstat, kstat_open) dnl _Must_ come before AC_FUNC_GETLOADAVG.
+AC_FUNC_GETLOADAVG
# Check out the wait reality.
AC_CHECK_HEADERS(sys/wait.h)
@@ -207,7 +210,7 @@ esac
MAINT_MAKEFILE=/dev/null
-if test -r $srcdir/maintMakefile; then
+if test -r "$srcdir/maintMakefile"; then
MAINT_MAKEFILE="$srcdir/maintMakefile"
fi
AC_SUBST_FILE(MAINT_MAKEFILE)