summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@redhat.com>1992-10-09 16:12:29 +0000
committerRoland McGrath <roland@redhat.com>1992-10-09 16:12:29 +0000
commite567c8d914358380003ab619942c1461151240c1 (patch)
treec67b337287143196abeee232d9668436a277e250 /configure.in
parent21d566bf51472d0ad834f0f96945a8835a731d1b (diff)
downloadgunmake-e567c8d914358380003ab619942c1461151240c1.tar.gz
Formerly configure.in.~3~
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 86e828b..c419713 100644
--- a/configure.in
+++ b/configure.in
@@ -18,11 +18,16 @@ AC_HAVE_HEADERS(limits.h sys/param.h)
AC_MINUS_C_MINUS_O
AC_SUBST(LIBOBJS)
+ifdef([notdef],
+# Apparently some systems have a buggy glob function in their C library.
+# So forget them and always use ours.
AC_COMPILE_CHECK(POSIX.2 glob functions,
[#include <glob.h>],
[glob (0, 0, 0, 0);],
AC_DEFINE(HAVE_GLOB_H),
[LIBOBJS="$LIBOBJS glob/libglob.a"])
+)
+LIBOBJS="$LIBOBJS glob/libglob.a"
AC_HAVE_FUNCS(getdtablesize sys_siglist _sys_siglist \
dup2 getcwd sigsetmask getgroups setlinebuf)