summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@redhat.com>1993-01-26 02:24:51 +0000
committerRoland McGrath <roland@redhat.com>1993-01-26 02:24:51 +0000
commit2603a605263fb95ba9c61d3fadb72865f2941491 (patch)
treee1da765bfcc386539cd6b66977a42953e3ab9234 /configure.in
parent9a1a8d0dc616921d6f8dc70eebebca1da9e91d81 (diff)
downloadgunmake-2603a605263fb95ba9c61d3fadb72865f2941491.tar.gz
Formerly configure.in.~14~
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 97e67a9..135d707 100644
--- a/configure.in
+++ b/configure.in
@@ -40,9 +40,20 @@ dnl Check out the wait reality.
AC_HAVE_HEADERS(sys/wait.h) AC_HAVE_FUNCS(waitpid wait3)
AC_COMPILE_CHECK(union wait, [#include <sys/types.h>
#include <sys/wait.h>],
- [union wait status; return wait (&status);],
+ [union wait status; int pid; pid = wait (&status);
+#ifdef WEXITSTATUS
+/* Some POSIXoid systems have both the new-style macros and the old
+ `union wait' type, and they don't work together. If `union wait'
+ conflicts with WEXITSTATUS et al, we don't want to use it at all. */
+if (WEXITSTATUS (status) != 0) pid = -1;
+#endif
+],
AC_DEFINE(HAVE_UNION_WAIT))
+AC_COMPILE_CHECK(sys_siglist declaration in signal.h,
+ [#include <signal.h>], [char *msg = *(sys_siglist + 1);],
+ AC_DEFINE(SYS_SIGLIST_DECLARED))
+
# The presence of the following is not meant to imply
# that make necessarily works on those systems.
AC_DYNIX_SEQ