summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@redhat.com>1993-01-22 22:16:40 +0000
committerRoland McGrath <roland@redhat.com>1993-01-22 22:16:40 +0000
commit21c1a556659b34b402a22122367d6836cd31525d (patch)
tree5d12ebaa0ccd06e3164aca8cba68425641c37152 /configure.in
parentc50958dd46f4e7d1bd37628ce257bca2101d1b99 (diff)
downloadgunmake-21c1a556659b34b402a22122367d6836cd31525d.tar.gz
Formerly configure.in.~13~
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 10 insertions, 13 deletions
diff --git a/configure.in b/configure.in
index fd04ab9..97e67a9 100644
--- a/configure.in
+++ b/configure.in
@@ -2,6 +2,10 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT(vpath.c) dnl A distinctive file to look for in srcdir.
AC_CONFIG_HEADER(config.h)
+# We want these before the checks, so the checks can modify their values.
+test -z "$CFLAGS" && CFLAGS=-g AC_SUBST(CFLAGS)
+test -z "$LDFLAGS" && LDFLAGS=-g AC_SUBST(LDFLAGS)
+
AC_PROG_CC
AC_PROG_INSTALL
AC_PROG_RANLIB
@@ -19,6 +23,7 @@ AC_RETSIGTYPE
AC_HAVE_HEADERS(limits.h sys/param.h fcntl.h)
AC_MINUS_C_MINUS_O
AC_CONST dnl getopt needs this.
+AC_USG
AC_SUBST(LIBOBJS)
@@ -31,26 +36,18 @@ AC_SETVBUF_REVERSED
AC_GETLOADAVG
AC_STRCOLL
-dnl Look for waitpid first.
-AC_COMPILE_CHECK(waitpid, [#include <sys/types.h>
+dnl Check out the wait reality.
+AC_HAVE_HEADERS(sys/wait.h) AC_HAVE_FUNCS(waitpid wait3)
+AC_COMPILE_CHECK(union wait, [#include <sys/types.h>
#include <sys/wait.h>],
- [return waitpid (-1, (int *) 0, WNOHANG);],
- AC_DEFINE(HAVE_WAITPID),
- dnl No waitpid; try wait3.
- AC_COMPILE_CHECK(wait3, [#include <sys/wait.h>],
- [return wait3 (0, WNOHANG, 0);],
- AC_DEFINE(HAVE_SYS_WAIT)))
-
-AC_USG
+ [union wait status; return wait (&status);],
+ AC_DEFINE(HAVE_UNION_WAIT))
# The presence of the following is not meant to imply
# that make necessarily works on those systems.
AC_DYNIX_SEQ
AC_XENIX_DIR
-test -n "$CFLAGS" && CFLAGS=-g AC_SUBST(CFLAGS)
-test -n "$LDFLAGS" && LDFLAGS=-g AC_SUBST(LDFLAGS)
-
AC_OUTPUT(Makefile build.sh glob/Makefile)
dnl Local Variables: