From 98cb3b26f4043c9a83029c21855ff61b7601e611 Mon Sep 17 00:00:00 2001
From: Igor Pashev <igor.pashev@nexenta.com>
Date: Wed, 24 Oct 2012 14:48:04 +0400
Subject: Initial commit from cibs/examples

---
 pcre/Makefile    |  22 +++++++++++
 pcre/pcre.p5m    | 109 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
 pcre/pcrecpp.p5m |  21 +++++++++++
 3 files changed, 152 insertions(+)
 create mode 100644 pcre/Makefile
 create mode 100644 pcre/pcre.p5m
 create mode 100644 pcre/pcrecpp.p5m

(limited to 'pcre')

diff --git a/pcre/Makefile b/pcre/Makefile
new file mode 100644
index 0000000..610fcec
--- /dev/null
+++ b/pcre/Makefile
@@ -0,0 +1,22 @@
+include /usr/share/cibs/rules/ips.mk
+include /usr/share/cibs/rules/archive.mk
+include /usr/share/cibs/rules/autotools.mk
+include /usr/share/cibs/rules/32.mk
+include /usr/share/cibs/rules/64.mk
+
+summary := Perl Compatible Regular Expressions
+license := BSD
+license-file := LICENCE
+
+# build-conflicts +=
+
+home     := http://www.pcre.org/
+name     := pcre
+version  := 8.31
+archive  := $(name)-$(version).tar.bz2
+download := http://sourceforge.net/projects/$(name)/files/$(name)/$(version)/$(archive)/download
+checksum := \
+     md5:1c9a276af932b5599157f96e945391f0 \
+    sha1:1132276bb8bea7cb0662210fb812fbef7791621f \
+  sha256:5778a02535473c7ee7838ea598c19f451e63cf5eec0bf0307a688301c9078c3c \
+    size:1257162
diff --git a/pcre/pcre.p5m b/pcre/pcre.p5m
new file mode 100644
index 0000000..b016eff
--- /dev/null
+++ b/pcre/pcre.p5m
@@ -0,0 +1,109 @@
+set name=pkg.fmri value=pkg:/library/pcre@$(ips-version)
+set name=pkg.summary value="$(summary)"
+set name=info.upstream-url value="$(home)"
+set name=info.source_url value="$(download)"
+license $(license-file) license="$(license)"
+
+<transform file dir link path=.*pcre-config.* -> default facet.devel true>
+
+dir path=usr
+dir path=usr/include
+dir path=usr/lib
+dir path=usr/lib/$(MACH64)
+dir path=usr/lib/$(MACH64)/pkgconfig
+dir path=usr/lib/pkgconfig
+dir path=usr/share
+dir path=usr/share/man
+dir path=usr/share/man/man1
+dir path=usr/share/man/man3
+file path=usr/bin/$(MACH64)/pcre-config
+file path=usr/bin/pcre-config
+file path=usr/include/pcre_scanner.h
+file path=usr/include/pcre_stringpiece.h
+file path=usr/include/pcre.h
+file path=usr/include/pcreposix.h
+file path=usr/lib/$(MACH64)/libpcre.so.1.0.1
+file path=usr/lib/$(MACH64)/libpcreposix.so.0.0.1
+file path=usr/lib/$(MACH64)/pkgconfig/libpcre.pc
+file path=usr/lib/$(MACH64)/pkgconfig/libpcreposix.pc
+file path=usr/lib/libpcre.so.1.0.1
+file path=usr/lib/libpcreposix.so.0.0.1
+file path=usr/lib/pkgconfig/libpcre.pc
+file path=usr/lib/pkgconfig/libpcreposix.pc
+file path=usr/share/man/man1/pcre-config.1
+file path=usr/share/man/man3/pcre_assign_jit_stack.3
+file path=usr/share/man/man3/pcre_compile.3
+file path=usr/share/man/man3/pcre_compile2.3
+file path=usr/share/man/man3/pcre_config.3
+file path=usr/share/man/man3/pcre_copy_named_substring.3
+file path=usr/share/man/man3/pcre_copy_substring.3
+file path=usr/share/man/man3/pcre_dfa_exec.3
+file path=usr/share/man/man3/pcre_exec.3
+file path=usr/share/man/man3/pcre_free_study.3
+file path=usr/share/man/man3/pcre_free_substring_list.3
+file path=usr/share/man/man3/pcre_free_substring.3
+file path=usr/share/man/man3/pcre_fullinfo.3
+file path=usr/share/man/man3/pcre_get_named_substring.3
+file path=usr/share/man/man3/pcre_get_stringnumber.3
+file path=usr/share/man/man3/pcre_get_stringtable_entries.3
+file path=usr/share/man/man3/pcre_get_substring_list.3
+file path=usr/share/man/man3/pcre_get_substring.3
+file path=usr/share/man/man3/pcre_jit_stack_alloc.3
+file path=usr/share/man/man3/pcre_jit_stack_free.3
+file path=usr/share/man/man3/pcre_maketables.3
+file path=usr/share/man/man3/pcre_pattern_to_host_byte_order.3
+file path=usr/share/man/man3/pcre_refcount.3
+file path=usr/share/man/man3/pcre_study.3
+file path=usr/share/man/man3/pcre_utf16_to_host_byte_order.3
+file path=usr/share/man/man3/pcre_version.3
+file path=usr/share/man/man3/pcre.3
+file path=usr/share/man/man3/pcre16.3
+file path=usr/share/man/man3/pcreapi.3
+file path=usr/share/man/man3/pcrebuild.3
+file path=usr/share/man/man3/pcrecallout.3
+file path=usr/share/man/man3/pcrecompat.3
+file path=usr/share/man/man3/pcrejit.3
+file path=usr/share/man/man3/pcrelimits.3
+file path=usr/share/man/man3/pcrematching.3
+file path=usr/share/man/man3/pcrepartial.3
+file path=usr/share/man/man3/pcrepattern.3
+file path=usr/share/man/man3/pcreperform.3
+file path=usr/share/man/man3/pcreposix.3
+file path=usr/share/man/man3/pcreprecompile.3
+file path=usr/share/man/man3/pcresample.3
+file path=usr/share/man/man3/pcrestack.3
+file path=usr/share/man/man3/pcresyntax.3
+file path=usr/share/man/man3/pcreunicode.3
+link path=usr/lib/$(MACH64)/libpcre.so target=libpcre.so.1.0.1
+link path=usr/lib/$(MACH64)/libpcre.so.1 target=libpcre.so.1.0.1
+link path=usr/lib/$(MACH64)/libpcreposix.so target=libpcreposix.so.0.0.1
+link path=usr/lib/$(MACH64)/libpcreposix.so.0 target=libpcreposix.so.0.0.1
+link path=usr/lib/libpcre.so target=libpcre.so.1.0.1
+link path=usr/lib/libpcre.so.1 target=libpcre.so.1.0.1
+link path=usr/lib/libpcreposix.so target=libpcreposix.so.0.0.1
+link path=usr/lib/libpcreposix.so.0 target=libpcreposix.so.0.0.1
+link path=usr/share/man/man3/pcre16_assign_jit_stack.3 target=pcre_assign_jit_stack.3
+link path=usr/share/man/man3/pcre16_compile.3 target=pcre_compile.3
+link path=usr/share/man/man3/pcre16_compile2.3 target=pcre_compile2.3
+link path=usr/share/man/man3/pcre16_config.3 target=pcre_config.3
+link path=usr/share/man/man3/pcre16_copy_named_substring.3 target=pcre_copy_named_substring.3
+link path=usr/share/man/man3/pcre16_copy_substring.3 target=pcre_copy_substring.3
+link path=usr/share/man/man3/pcre16_dfa_exec.3 target=pcre_dfa_exec.3
+link path=usr/share/man/man3/pcre16_exec.3 target=pcre_exec.3
+link path=usr/share/man/man3/pcre16_free_study.3 target=pcre_free_study.3
+link path=usr/share/man/man3/pcre16_free_substring_list.3 target=pcre_free_substring_list.3
+link path=usr/share/man/man3/pcre16_free_substring.3 target=pcre_free_substring.3
+link path=usr/share/man/man3/pcre16_fullinfo.3 target=pcre_fullinfo.3
+link path=usr/share/man/man3/pcre16_get_named_substring.3 target=pcre_get_named_substring.3
+link path=usr/share/man/man3/pcre16_get_stringnumber.3 target=pcre_get_stringnumber.3
+link path=usr/share/man/man3/pcre16_get_stringtable_entries.3 target=pcre_get_stringtable_entries.3
+link path=usr/share/man/man3/pcre16_get_substring_list.3 target=pcre_get_substring_list.3
+link path=usr/share/man/man3/pcre16_get_substring.3 target=pcre_get_substring.3
+link path=usr/share/man/man3/pcre16_jit_stack_alloc.3 target=pcre_jit_stack_alloc.3
+link path=usr/share/man/man3/pcre16_jit_stack_free.3 target=pcre_jit_stack_free.3
+link path=usr/share/man/man3/pcre16_maketables.3 target=pcre_maketables.3
+link path=usr/share/man/man3/pcre16_pattern_to_host_byte_order.3 target=pcre_pattern_to_host_byte_order.3
+link path=usr/share/man/man3/pcre16_refcount.3 target=pcre_refcount.3
+link path=usr/share/man/man3/pcre16_study.3 target=pcre_study.3
+link path=usr/share/man/man3/pcre16_utf16_to_host_byte_order.3 target=pcre_utf16_to_host_byte_order.3
+link path=usr/share/man/man3/pcre16_version.3 target=pcre_version.3
diff --git a/pcre/pcrecpp.p5m b/pcre/pcrecpp.p5m
new file mode 100644
index 0000000..e2eb275
--- /dev/null
+++ b/pcre/pcrecpp.p5m
@@ -0,0 +1,21 @@
+
+set name=pkg.fmri value=pkg:/library/pcrecpp@$(ips-version)
+set name=pkg.summary value="$(summary), C++ library"
+set name=info.upstream-url value="$(home)"
+set name=info.source_url value="$(download)"
+license $(license-file) license="$(license)"
+
+depend fmri=pkg:/library/pcre@$(ips-version) type=incorporate
+
+file path=usr/include/pcrecpp.h
+file path=usr/include/pcrecpparg.h
+file path=usr/lib/$(MACH64)/libpcrecpp.so.0.0.0
+file path=usr/lib/$(MACH64)/pkgconfig/libpcrecpp.pc
+file path=usr/lib/libpcrecpp.so.0.0.0
+file path=usr/lib/pkgconfig/libpcrecpp.pc
+file path=usr/share/man/man3/pcrecpp.3
+link path=usr/lib/$(MACH64)/libpcrecpp.so target=libpcrecpp.so.0.0.0
+link path=usr/lib/$(MACH64)/libpcrecpp.so.0 target=libpcrecpp.so.0.0.0
+link path=usr/lib/libpcrecpp.so target=libpcrecpp.so.0.0.0
+link path=usr/lib/libpcrecpp.so.0 target=libpcrecpp.so.0.0.0
+
-- 
cgit v1.2.3