summaryrefslogtreecommitdiff
path: root/openssl1.0.0/patches/29-devcrypto_engine-1.0.1c.patch
diff options
context:
space:
mode:
Diffstat (limited to 'openssl1.0.0/patches/29-devcrypto_engine-1.0.1c.patch')
-rw-r--r--openssl1.0.0/patches/29-devcrypto_engine-1.0.1c.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/openssl1.0.0/patches/29-devcrypto_engine-1.0.1c.patch b/openssl1.0.0/patches/29-devcrypto_engine-1.0.1c.patch
new file mode 100644
index 0000000..5cd6eed
--- /dev/null
+++ b/openssl1.0.0/patches/29-devcrypto_engine-1.0.1c.patch
@@ -0,0 +1,41 @@
+diff -dubr source/engines/Makefile dev/engines/Makefile
+--- source/engines/Makefile 2010-08-25 01:46:58.000000000 +0400
++++ dev/engines/Makefile 2012-10-30 14:30:06.780716474 +0400
+@@ -27,6 +27,7 @@
+
+ LIB=$(TOP)/libcrypto.a
+ LIBNAMES= 4758cca aep atalla cswift gmp chil nuron sureware ubsec padlock capi
++LIBNAMES += devcrypto
+
+ LIBSRC= e_4758cca.c \
+ e_aep.c \
+@@ -51,6 +52,9 @@
+ e_padlock.o \
+ e_capi.o
+
++LIBSRC += e_devcrypto.c
++LIBOBJ += e_devcrypto.o
++
+ SRC= $(LIBSRC)
+
+ EXHEADER=
+@@ -63,7 +67,8 @@
+ e_nuron_err.c e_nuron_err.h \
+ e_sureware_err.c e_sureware_err.h \
+ e_ubsec_err.c e_ubsec_err.h \
+- e_capi_err.c e_capi_err.h
++ e_capi_err.c e_capi_err.h \
++ e_devcrypto_err.c e_devcrypto_err.h
+
+ ALL= $(GENERAL) $(SRC) $(HEADER)
+
+@@ -78,7 +83,7 @@
+ for l in $(LIBNAMES); do \
+ $(MAKE) -f ../Makefile.shared -e \
+ LIBNAME=$$l LIBEXTRAS=e_$$l.o \
+- LIBDEPS='-L.. -lcrypto $(EX_LIBS)' \
++ LIBDEPS='-L.. -lcrypto -lcryptoutil $(EX_LIBS)' \
+ link_o.$(SHLIB_TARGET); \
+ done; \
+ else \
+Only in dev/engines: Makefile.orig