summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--python2.7/Makefile9
-rw-r--r--python2.7/libpython.p5m11
2 files changed, 18 insertions, 2 deletions
diff --git a/python2.7/Makefile b/python2.7/Makefile
index eedd968..88547f3 100644
--- a/python2.7/Makefile
+++ b/python2.7/Makefile
@@ -34,8 +34,13 @@ configure-options += \
--with-dbmliborder=bdb:gdbm \
--with-system-expat \
--with-system-ffi \
- --enable-static \
- --libdir=/usr/lib
+ --enable-shared \
+
+
+# Ensure Makefile goes into /usr/lib/pythonX.Y/config
+# (where rumtime will look it for),
+# not into /usr/lib/amd64/pythonX.Y/config:
+install-%-stamp: make-vars += LIBPL=$(prefix)/lib/python$(pyver)/config
checksum-Python-2.7.3.tar.bz2 := \
md5:c57477edd6d18bd9eeca2f21add73919 \
diff --git a/python2.7/libpython.p5m b/python2.7/libpython.p5m
new file mode 100644
index 0000000..d468766
--- /dev/null
+++ b/python2.7/libpython.p5m
@@ -0,0 +1,11 @@
+set name=pkg.fmri value=pkg:/library/libpython$(pyver)@$(ips-version)
+set name=pkg.summary value="Shared Python runtime library (version $(pyver))"
+set name=info.upstream-url value="$(home)"
+set name=info.source-url value="$(download)"
+
+license $(license-file) license="$(license)"
+
+file path=usr/lib/$(mach64)/libpython$(pyver).so.1.0
+link path=usr/lib/$(mach64)/libpython$(pyver).so.1 target=libpython$(pyver).so.1.0
+link path=/usr/lib/python$(pyver)/config/libpython$(pyver).so \
+ target=../../$(mach64)/libpython$(pyver).so.1