pandoc (0.43) unstable; urgency=low
[ John MacFarlane ]
* The focus of this release is performance. The markdown parser
is about five times faster than in 0.42, based on benchmarks
with the TextMate manual.
* Main.hs: Replaced CRFilter and tabFilter with single function
tabFilter, which operates on the whole string rather than breaking
it into lines, and handles dos-style line-endings as well as tabs.
* Added separate LaTeX reader and native reader tests; removed
round-trip tests.
* Text.Pandoc.Shared:
+ Removed tabsToSpaces and tabsInLine (they were used only in Main.hs.)
+ General code cleanup (to elimante warnings when compiling with -Wall.)
+ Added 'wrapped' function, which helps wrap text into paragraphs,
using the prettyprinting library.
+ Rewrote charsInBalanced and charsInBalanced'.
- Documented restriction: open and close must be distinct characters.
- Rearranged options for greater efficiency.
- Bug fix: Changed inner call to charsInBalanced inside
charsInBalanced' to charsInBalanced'.
+ anyLine now requires that the line end with a newline (not eof).
This is a harmless assumption, since we always add newlines to the
end of a block before parsing with anyLine, and it yields a 10% speed
boost.
+ Removed unnecessary 'try' in anyLine.
+ Removed unneeded 'try' from romanNumeral parser.
+ Use notFollowedBy instead of notFollowedBy' in charsInBalanced.
+ Removed unneeded 'try' in parseFromString.
+ Removed unneeded 'try' from stringAnyCase. (Now it behaves
like 'string'.)
+ Changed definition of 'enclosed' in Text.Pandoc.Shared so that
'try' is not automatically applied to the 'end' parser. Added
'try' in calls to 'enclosed' where needed. Slight speed increase.
* Writers:
+ Replaced individual wrapping routines in RST, Man, and Markdown
writers with 'wrapped' from Text.Pandoc.Shared.
+ Rewrote LaTeX writer to use the prettyprinting library,
so we get word wrapping, etc.
+ Modified latex writer tests for new latex writer using prettyprinter.
+ Fixed bug in LaTeX writer: autolinks would not cause
'\usepackage{url}' to be put in the document header. Also, changes
to state in enumerated list items would be overwritten.
+ In Markdown writer, escape paragraphs that begin with ordered list
markers, so they don't get interpreted as ordered lists.
* Text.Pandoc.Reades.LaTeX:
+ Fixed bug in LaTeX reader, which wrongly assumed that the roman
numeral after "enum" in "setcounter" would consist entirely of
"i"s. 'enumiv' is legitimate.
+ LaTeX command and environment names can't contain numbers.
+ Rearranged order of parsers in inline for slight speed improvement.
+ Added '`' to special characters and 'unescapedChar'.
* Text.Pandoc.Readers.RST:
+ Removed unneeded try's in RST reader; also minor code cleanup.
+ Removed tabchar.
+ Rearranged parsers in inline (doubled speed).
* Text.Pandoc.Readers.Markdown:
+ Skip notes parsing if running in strict mode. (This yields a nice
speed improvement in strict mode.)
+ Simplify autolink parsing code, using Network.URI to test for
URIs. Added dependency on network library to debian/control and
pandoc.cabal.
+ More perspicuous definition of nonindentSpaces.
+ Removed unneeded 'try' in 'rawLine'.
+ Combined linebreak and whitespace into a new whitespace parser, to
avoid unnecessary reparsing of space characters.
+ Removed unnecessary 'try' in 'codeBlock', 'ellipses', 'noteMarker',
'multilineRow', 'dashedLine', 'rawHtmlBlocks'.
+ Use lookAhead in parsers for setext headers and definition lists
to see if the next line begins appropriately; if not, don't waste
any more time parsing.
+ Don't require blank lines after code block. (It's sufficient to
end code block with a nonindented line.)
+ Changed definition of 'emph': italics with '_' must not
be followed by an alphanumeric character. This is to help
prevent interpretation of e.g. [LC_TYPE]: my_type as
'[LCTYPE]:mytype'.
+ Improved Markdown.pl-compatibility in referenceLink: the two parts
of a reference-style link may be separated by one space, but not
more... [a] [link], [not] [a link].
+ Fixed markdown inline code parsing so it better accords with
Markdown.pl: the marker for the end of the code section is a clump
of the same number of `'s with which the section began, followed
by a non-` character. So, for example,
` h ``` i ` -> h ``` i
.
+ Split 'title' into 'linkTitle' and 'referenceTitle', since the
rules are slightly different.
+ Rewrote 'para' for greater efficiency.
+ Rewrote link parsers for greater efficiency.
+ Removed redundant 'referenceLink' in definition of inline (it's
already in 'link').
+ Refactored escapeChar so it doesn't need 'try'.
+ Refactored hrule for performance in Markdown reader.
+ More intelligent rearranging of 'inline' so that most frequently
used parsers are tried first.
+ Removed tabchar parser, as whitespace handles tabs anyway.
* Text.Pandoc.CharacterReferences:
+ Refactored.
+ Removed unnecessary 'try's for a speed improvement.
+ Removed unnecessary '&' and ';' from the entity table.
* Build process:
+ Makefile: Get VERSION from cabal file, not Main.hs.
+ Modified MacPorts Portfile:
- Depend on haddock
- Build and install libraries and library documentation in
addition to pandoc executable
- Added template item for md5 sum in Portfile.in.
- Incorporated changes from MacPorts repository (r28278).
+ FreeBSD port: Don't try to generate distinfo in Makefile.
It can be made using 'make makesum' in FreeBSD.
+ Make both freebsd and macports targets depend on tarball.
* Website and documentation:
+ Updated INSTALL instructions.
+ Added pandocwiki demo to website.
+ Removed local references to Portfile, since pandoc is now in the
MacPorts repository.
-- Recai Oktaş Sun, 02 Sep 2007 15:50:11 +0300
pandoc (0.42) unstable; urgency=low
[ John MacFarlane ]
* Main.hs: Use utf8 conversion on the extra files loaded with
the -H, -C, -B, and -A options. This fixes problems with unicode
characters in these files.
* Exposed Text.Pandoc.ASCIIMathML, since it is imported in
Text.Pandoc.Readers.HTML and without it we get a linking error when
using the library.
* Markdown reader:
+ Added new rule for enhanced markdown ordered lists: if the list
marker is a capital letter followed by a period (including a
single-letter capital roman numeral), then it must be followed by
at least two spaces. The point of this is to avoid accidentally
treating people's initials as list markers: a paragraph might begin,
"B. Russell was an English philosopher," and this shouldn't be
treated as a list. Documented change in README.
+ Blocks that start with "p. " and a digit are no longer treated
as ordered lists (it's a page number).
+ Added a needed 'try' to listItem.
+ Removed check for a following setext header in endline.
A full test is too inefficient (doubles benchmark time), and the
substitute we had before is not 100% accurate.
+ Don't use Code elements for autolinks if --strict specified.
* LaTeX writer: When a footnote ends with a Verbatim environment, the
close } of the footnote cannot occur on the same line or an error occurs.
Fixed this by adding a newline before the closing } of every footnote.
* HTML writer:
+ Removed incorrect "{}" around style information in HTML tables.
Column widths now work properly in HTML.
+ If --strict option is specified (and --toc is not), don't include
identifiers in headers, for better Markdown compatibility.
* Build process:
+ Separated $(web_dest) and website targets.
+ In website, index.txt is now constructed from template index.txt.in.
+ Added freebsd target to Markefile. This creates the freebsd Makefile
from Makefile.in, and creates distinfo. Removed Makefile and distinfo
from the repository.
+ Added macport target to Makefile. Portfile is built from template
Portfile.in.
+ Removed OSX package targets. (Too many difficulties involving
dependencies on dynamic libraries.)
+ More complete INSTALL instructions for all architectures.
* Website:
+ Added a programming demo, pandocwiki.
[ Recai Oktaş ]
* Do not forget to close pandoc's ITP. Closes: #391666
-- Recai Oktaş Sun, 26 Aug 2007 22:51:32 +0300
pandoc (0.41) unstable; urgency=low
[ John MacFarlane ]
* Fixed bugs in HTML reader:
+ Skip material at end *only if*