aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog15
-rw-r--r--debian/control5
-rw-r--r--debian/pandoc-doc.doc-base4
-rwxr-xr-xdebian/rules6
4 files changed, 21 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 6a7d6abf0..a0945d91f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,18 @@
+pandoc (0.47) unstable; urgency=low
+
+ [ Recai Oktaş ]
+
+ * Debian packaging changes:
+
+ + Migrate to GHC 6.8.2. Closes: #461606
+ + Add new dependencies libghc6-regex-compat-dev and libghc6-uulib-dev.
+ + Remove the code in debian/rules which attempts to remove empty ghc6.6
+ include directory. This code may cause an installation failure for the
+ -dev package. Closes: #460658
+ + Fix doc-base to prevent a lintian warning.
+
+ -- Recai Oktaş <roktas@debian.org> Sat, 09 Feb 2008 04:41:46 +0200
+
pandoc (0.46) unstable; urgency=low
[ John MacFarlane ]
diff --git a/debian/control b/debian/control
index 1300449a6..c83a813e3 100644
--- a/debian/control
+++ b/debian/control
@@ -2,9 +2,8 @@ Source: pandoc
Section: text
Priority: optional
Maintainer: Recai Oktaş <roktas@debian.org>
-Build-Depends: debhelper (>= 4.0.0), haskell-devscripts (>=0.5.12), ghc6 (>= 6.6-1), libghc6-xhtml-dev, libghc6-mtl-dev, libghc6-network-dev, perl
+Build-Depends: debhelper (>= 4.0.0), haskell-devscripts (>=0.5.12), ghc6 (>= 6.8.2-1), libghc6-xhtml-dev, libghc6-mtl-dev, libghc6-network-dev, libghc6-regex-compat-dev, libghc6-uulib-dev, perl
Build-Depends-Indep: haddock
-Build-Conflicts: ghc6 (>= 6.8), ghc6 (<= 6.4)
Standards-Version: 3.7.3
Homepage: http://johnmacfarlane.net/pandoc/
XS-Vcs-Svn: http://pandoc.googlecode.com/svn/trunk
@@ -38,7 +37,7 @@ Description: general markup converter
Package: libghc6-pandoc-dev
Section: libdevel
Architecture: any
-Depends: ${haskell:Depends}, libghc6-xhtml-dev, libghc6-mtl-dev, libghc6-network-dev
+Depends: ${haskell:Depends}, libghc6-xhtml-dev, libghc6-mtl-dev, libghc6-network-dev, libghc6-regex-compat-dev, libghc6-uulib-dev
Suggests: pandoc-doc
Description: general markup converter
Pandoc is a Haskell library for converting from one markup format to
diff --git a/debian/pandoc-doc.doc-base b/debian/pandoc-doc.doc-base
index e9a62fe39..6979bc6d3 100644
--- a/debian/pandoc-doc.doc-base
+++ b/debian/pandoc-doc.doc-base
@@ -7,5 +7,5 @@ Abstract: This is the documentation of Pandoc, which includes the API
Section: Apps/Programming
Format: html
-Index: /usr/share/doc/pandoc-doc/html/index.html
-Files: /usr/share/doc/pandoc-doc/html/*.html
+Index: /usr/share/doc/pandoc-doc/html/pandoc/index.html
+Files: /usr/share/doc/pandoc-doc/html/pandoc/*.html
diff --git a/debian/rules b/debian/rules
index a9fe650bf..35f02c99a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -38,13 +38,13 @@ configure-stamp:
dh_testdir
$(MAKE) configure
- touch configure-stamp
+ touch $@
build: build-stamp
build-stamp: configure-stamp
dh_testdir
- touch build-stamp
+ touch $@
clean:
dh_testdir
@@ -63,8 +63,6 @@ install: build
dh_haskell -a
- # Remove empty directories, which lintian complains about.
- find debian/libghc6-$(THIS)-dev -type d -name 'include' -empty -delete
# Hack! Cabal builds executables while building libraries. Move these
# files to top dir where the Makefile install target expects to find.
# See "BUGS" section at the following document: