aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/control2
-rw-r--r--debian/pandoc-doc.doc-base4
-rw-r--r--debian/pandoc-doc.docs2
-rw-r--r--debian/rules21
5 files changed, 25 insertions, 10 deletions
diff --git a/debian/changelog b/debian/changelog
index 11eafeac7..7b0e0d674 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+pandoc (0.22) unstable; urgency=low
+
+ * Migrate to GHC 6.6. Modify the whole build system accordingly.
+
+ -- Recai Oktaş <roktas@debian.org> Tue, 24 Oct 2006 07:48:30 +0300
+
pandoc (0.21) unstable; urgency=low
* Revamp and split Debian package. Closes: #391666.
diff --git a/debian/control b/debian/control
index 24ad40f42..aa57a864d 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: pandoc
Section: text
Priority: optional
Maintainer: Recai Oktaş <roktas@debian.org>
-Build-Depends: debhelper (>= 4.0.0), haskell-devscripts (>=0.5.11), ghc6 (>=6.4), perl
+Build-Depends: debhelper (>= 4.0.0), haskell-devscripts (>=0.5.12), ghc6 (>= 6.6-1), libghc6-html-dev (>= 1.0-1), perl
Build-Depends-Indep: haddock
Standards-Version: 3.7.2.0
diff --git a/debian/pandoc-doc.doc-base b/debian/pandoc-doc.doc-base
index 3fd80e7d9..e9a62fe39 100644
--- a/debian/pandoc-doc.doc-base
+++ b/debian/pandoc-doc.doc-base
@@ -7,5 +7,5 @@ Abstract: This is the documentation of Pandoc, which includes the API
Section: Apps/Programming
Format: html
-Index: /usr/share/doc/pandoc-doc/index.html
-Files: /usr/share/doc/pandoc-doc/*.html /usr/share/doc/pandoc-doc/pandoc/*.html
+Index: /usr/share/doc/pandoc-doc/html/index.html
+Files: /usr/share/doc/pandoc-doc/html/*.html
diff --git a/debian/pandoc-doc.docs b/debian/pandoc-doc.docs
index cf7cb60ed..1936cc1d4 100644
--- a/debian/pandoc-doc.docs
+++ b/debian/pandoc-doc.docs
@@ -1 +1 @@
-html/*
+html
diff --git a/debian/rules b/debian/rules
index 45a999435..7c0f98547 100644
--- a/debian/rules
+++ b/debian/rules
@@ -9,23 +9,32 @@
# Licensed under the GNU General Public License, version 2.
# See the file 'http://www.gnu.org/copyleft/gpl.txt'.
-THIS := pandoc
+THIS := $(shell sed -ne 's/^Source: \(.*\)/\1/p' debian/control)
+PREFIX := /usr
+DESTDIR := debian/$(THIS)
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+ifeq (1,$(DH_VERBOSE))
+HCFLAGS+=-v
+endif
+
# Handle noopt in DEB_BUILD_OPTIONS. Emulate CFLAGS (as HCFLAGS).
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-MAKE_ENVVARS := HCFLAGS=-O0
+HCFLAGS+=-O0
else
-MAKE_ENVVARS := HCFLAGS=-O2
+# No optimisation seems optimum.
+HCFLAGS+=-O0
endif
-MAKE_ENVVARS += PREFIX=/usr
+
+# Export all variables which will be used in various stages of build process.
+export PREFIX DESTDIR HCFLAGS
configure: configure-stamp
configure-stamp:
dh_testdir
- $(MAKE_ENVVARS) $(MAKE) configure
+ $(MAKE) configure
touch configure-stamp
@@ -58,7 +67,7 @@ install: build
# http://www.n-heptane.com/nhlab/repos/cabalDebianTemplate/INSTRUCTIONS.txt
find debian/libghc6-$(THIS)-dev -type d -name 'bin' -true | \
while read bin; do mv $$bin/* .; rm -rf $$bin; done
- DESTDIR=debian/$(THIS) $(MAKE_ENVVARS) $(MAKE) install
+ $(MAKE) install
build-indep: build-indep-stamp
build-indep-stamp: