aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6f1873b2..0400145b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,6 +11,7 @@ AC_PREREQ([2.60])
AC_CONFIG_SRCDIR(src/Makefile.pamphlet)
+oa_use_libtool_for_shared_lib=yes
# Tell Libtool to assume `dlopen' so that it does not have to
# emulate it.
AC_LIBTOOL_DLOPEN
@@ -18,8 +19,18 @@ AC_LIBTOOL_WIN32_DLL
AC_PROG_LIBTOOL
AC_SUBST(LIBTOOL_DEPS)
# Give me extension of libraries
-AC_SUBST(shrext_cmds)
+eval shared_ext=\"$shrext_cmds\"
+AC_SUBST(shared_ext)
AC_SUBST(libext)
+# Don't use Libtool for building actual DLLs on MinGW and Cygwin
+case $host in
+ *mingw*|*cygwin*)
+ oa_use_libtool_for_shared_lib=no
+ ;;
+ *)
+ ;;
+esac
+AC_SUBST(oa_use_libtool_for_shared_lib)
axiom_optimize_options=speed
## Shall we proclaim safety?