aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac75
1 files changed, 39 insertions, 36 deletions
diff --git a/configure.ac b/configure.ac
index 9d805fdd..24306cf6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -421,28 +421,30 @@ esac
AC_SUBST(axiom_c_runtime_extra)
-AC_EGREP_HEADER([has_af_local],
- [#if HAVE_SYS_SOCKET_H
- # include <sys/socket.h>
- #else
- # include <winsock2.h>
- #endif
- #ifdef AF_LOCAL
- has_af_local
- #endif],
- [AC_DEFINE([HAVE_AF_LOCAL], [1], [Host has AF_LOCAL])])
-
-
-AC_EGREP_HEADER([has_af_unix],
- [#if HAVE_SYS_SOCKET_H
- # include <sys/socket.h>
- #else
- # include <winsock2.h>
- #endif
- #ifdef AF_UNIX
- has_af_unix
- #endif],
- [AC_DEFINE([HAVE_AF_UNIX], [1], [Host has AF_UNIX])])
+AC_EGREP_CPP([has_af_local],
+ [#if HAVE_SYS_SOCKET_H
+# include <sys/socket.h>
+#else
+# include <winsock2.h>
+#endif
+#ifdef AF_LOCAL
+ has_af_local
+#endif
+ ],
+ [AC_DEFINE([HAVE_AF_LOCAL], [1], [Host has AF_LOCAL])])
+
+
+AC_EGREP_CPP([has_af_unix],
+ [#if HAVE_SYS_SOCKET_H
+# include <sys/socket.h>
+#else
+# include <winsock2.h>
+#endif
+#ifdef AF_UNIX
+ has_af_unix
+#endif
+ ],
+ [AC_DEFINE([HAVE_AF_UNIX], [1], [Host has AF_UNIX])])
AC_CHECK_HEADERS([sys/wait.h])
@@ -462,20 +464,21 @@ AC_CHECK_DECLS([fork],
AC_CHECK_HEADERS([sys/ioctl.h pty.h util.h libutil.h termios.h])
AC_CHECK_DECLS([openpty],[],[],
[#if HAVE_PTY_H
- # include <pty.h>
- #endif
- #if HAVE_UTIL_H
- # include <util.h>
- #endif
- #if HAVE_SYS_IOCTL_H
- # include <sys/ioctl.h>
- #endif
- #if HAVE_TERMIOS_H
- # include <termios.h>
- #endif
- #if HAVE_LIBTUIL_H
- # include <libutil.h>
- #endif
+# include <pty.h>
+#endif
+#if HAVE_UTIL_H
+# include <util.h>
+#endif
+#if HAVE_SYS_IOCTL_H
+# include <sys/ioctl.h>
+#endif
+#if HAVE_TERMIOS_H
+# include <termios.h>
+#endif
+#if HAVE_LIBTUIL_H
+# include <sys/types.h>
+# include <libutil.h>
+#endif
])
if test x"$ac_cv_have_decl_openpty" = xyes; then \
AC_SEARCH_LIBS([openpty],[util])