aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 5 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 03d52d80..3a6a1320 100644
--- a/configure.ac
+++ b/configure.ac
@@ -492,15 +492,11 @@ else
fi
AC_SUBST(axiom_src_all)
AC_SUBST(axiom_use_x)
-if test x"$axiom_use_x" != xyes; then
- AC_MSG_NOTICE([HyperDoc is disabled because it depends on X11])
-else
- AC_CHECK_HEADER([regex.h],
- [axiom_src_all="$axiom_src_all all-hyper"
- axiom_src_subdirs="$axiom_src_subdirs hyper"
- AXIOM_MAKEFILE([src/hyper/Makefile])],
- [AC_MSG_NOTICE([HyperDoc is disabled.])])
-fi
+AC_CHECK_HEADER([regex.h],
+ [axiom_src_all="$axiom_src_all all-hyper"
+ axiom_src_subdirs="$axiom_src_subdirs hyper"
+ AXIOM_MAKEFILE([src/hyper/Makefile])],
+ [AC_MSG_NOTICE([HyperDoc is disabled.])])
axiom_host_has_libbfd=
## Check for these only if we are going to build GCL from source.