aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac44
1 files changed, 2 insertions, 42 deletions
diff --git a/configure.ac b/configure.ac
index 4e8c7af8..bc773a9e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,6 +26,8 @@ OPENAXIOM_GCL_HACKS
OPENAXIOM_HOST_DATA_PROPERTIES
OPENAXIOM_DYNAMIC_MODULE_SUPPORT
+OPENAXIOM_BUILD_TOOLS
+
axiom_src_subdirs="lib hyper lisp boot interp share algebra input etc doc"
AC_SUBST(axiom_src_subdirs)
@@ -49,30 +51,6 @@ AC_SUBST(oa_editor)
## It is vital that noweb is present in the build environement.
axiom_all_prerequisites=
-case $build in
- *linux*)
- # GNU/Linux systems come equipped with GNU Make, called `make'
- AC_CHECK_PROGS([MAKE], [make],
- [AC_MSG_ERROR([Make utility missing.])])
- ;;
- *)
- # Other systems tend to spell it `gmake' and such
- AC_CHECK_PROGS([MAKE], [gmake make],
- [AC_MSG_ERROR([Make utility missing.])])
- if ! $MAKE --version | grep 'GNU' 2>/dev/null; then
- AC_MSG_ERROR([OpenAxiom build system needs GNU Make.])
- fi
- ;;
-esac
-
-
-AC_PROG_INSTALL
-# AC_PROG_LN_S
-AC_CHECK_PROG([TOUCH], [touch],
- [touch], [AC_MSG_ERROR(['touch' program is missing.])])
-AC_CHECK_PROGS([MKTEMP], [mktemp])
-
-AC_PROG_AWK
AC_PATH_PROGS([HOST_AWK],[awk nawk gawk mawk])
@@ -86,24 +64,6 @@ fi
AC_CHECK_PROGS([MAKEINDEX], [makeindex])
-## ---------------------------------------
-## Make sure noweb executable is available
-## ---------------------------------------
-AC_CHECK_PROGS([NOTANGLE], [notangle])
-AC_CHECK_PROGS([NOWEAVE], [noweave])
-
-## In case noweb is missing we need to build our own.
-if test -z $NOTANGLE -o -z $NOWEAVE ; then
- ## Yes, but do we have the source files to build from?
- if test ! -d ${srcdir}/noweb; then
- AC_MSG_NOTICE([OpenAxiom requires noweb utilties])
- AC_MSG_ERROR([Please get the tarball of dependencies and reconfigure])
- fi
- NOTANGLE='$(axiom_build_bindir)/notangle'
- NOWEAVE='$(axiom_build_bindir)/noweave'
- axiom_all_prerequisites="$axiom_all_prerequisites all-noweb"
-fi
-
OPENAXIOM_LISP_FLAGS
OPENAXIOM_FILE_EXTENSIONS($axiom_lisp)