aboutsummaryrefslogtreecommitdiff
path: root/src/algebra/Makefile.am
diff options
context:
space:
mode:
authordos-reis <gdr@axiomatics.org>2013-06-18 00:47:44 +0000
committerdos-reis <gdr@axiomatics.org>2013-06-18 00:47:44 +0000
commit5d68f2651a08223febcc172a6cb49a6e92899034 (patch)
treedfea7ee6418af2cb05fd0747facf7ff92b4fa1c9 /src/algebra/Makefile.am
parent7db3376a614a5aeacc114c38002ea65e57046dc5 (diff)
downloadopen-axiom-5d68f2651a08223febcc172a6cb49a6e92899034.tar.gz
* algebra/catdef.spad.pamphlet (CommutativeOperatorCategory): New.
(CommutativeOperation): Likewise. * algebra/Makefile.am (oa_algebra_layer_0): Include them.
Diffstat (limited to 'src/algebra/Makefile.am')
-rw-r--r--src/algebra/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/algebra/Makefile.am b/src/algebra/Makefile.am
index 7a9e12eb..62706b10 100644
--- a/src/algebra/Makefile.am
+++ b/src/algebra/Makefile.am
@@ -1654,9 +1654,13 @@ $(OUT)/SYMBOL.$(FASLEXT): $(OUT)/ORDSET.$(FASLEXT) \
strap-2/PRIMARR.$(FASLEXT) strap-2/REF.$(FASLEXT) \
strap-2/STRING.$(FASLEXT)
+$(OUT)/COMOPC.$(FASLEXT): $(OUT)/BINOPC.$(FASLEXT)
+
+$(OUT)/COMOP.$(FASLEXT): $(OUT)/COMOPC.$(FASLEXT) $(OUT)/KOERCE.$(FASLEXT)
+
oa_algebra_layer_0 = \
TYPE BINOPC BINOP IDEMOPC SGPOPC SGPOP \
- MONOPC FUNCTOR \
+ MONOPC FUNCTOR COMOPC COMOP \
BASTYPE BASTYPE- SETCAT SETCAT- SGROUP SGROUP- \
LLINSET RLINSET LINSET ABELSG ABELSG- CHARNZ \
ABELGRP ABELGRP- ABELMON ABELMON- ORDTYPE ORDTYPE- \