aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordos-reis <gdr@axiomatics.org>2007-09-08 14:15:37 +0000
committerdos-reis <gdr@axiomatics.org>2007-09-08 14:15:37 +0000
commit157f4368b440536001959ad58167b09357273edc (patch)
tree7751794a4da9cb651610a157ef7f5fb9fd657a33 /configure.ac
parentbba4fa029c774d626f2c1159e6f2be78a315899c (diff)
downloadopen-axiom-157f4368b440536001959ad58167b09357273edc.tar.gz
* configure.ac.pamphlet (axiom_optimize_options): New substitued
variable. Genrate src/lisp/core.lisp at configure time. * configure.ac: Regenerate. * configure: Likewise. * config/setup-dep.mk ($(top_builddir)/src/lisp/core.lisp): New rule. src/lisp/ * Makefile.pamphlet (fasl_ext): New. Factor out the logic for computing file extensions. (FASLS): Rename from CORE. Use it to compute the list of files to load. ($(OUT)/lisp$(EXEEXT)): Adjust. (base-lisp$(EXEEXT)): sb-cltl2 module is no longer need. (core.lisp): Now depend on core.lisp.in. Regenerate if necessary. (mostlyclean-local): Remove FASLs too. * Makefile.in: Regenerate. * core.lisp.in: New. * core.lisp.pamphlet: Move content to core.lisp.in. Remove.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 473e6c8a..a826268b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,6 +13,7 @@ AC_CONFIG_SRCDIR(src/Makefile.pamphlet)
AC_PROG_LIBTOOL
AC_SUBST(LIBTOOL_DEPS)
+axiom_optimize_options=speed
## Shall we proclaim safety?
axiom_enable_checking=no # don't turn on checking by default.
AC_ARG_ENABLE([checking], [ --enable-checking turn runtime checking on],
@@ -21,9 +22,11 @@ AC_ARG_ENABLE([checking], [ --enable-checking turn runtime checking on],
*) AC_MSG_ERROR([erroneous value for --enable-checking]) ;;
esac])
if test x"axiom_enable_checking" = xyes; then
+ axiom_optimize_options="$axiom_optimize_options safety"
AC_MSG_NOTICE([runtime checking may increase compilation time])
fi
AC_SUBST(axiom_enable_checking)
+AC_SUBST(axiom_optimize_options)
axiom_src_subdirs="lib lisp boot interp share algebra input etc doc"
AC_SUBST(axiom_src_subdirs)
@@ -484,6 +487,7 @@ AXIOM_MAKEFILE([Makefile])
AXIOM_MAKEFILE([src/Makefile])
AXIOM_MAKEFILE([src/lib/Makefile])
AXIOM_MAKEFILE([src/lisp/Makefile])
+AC_CONFIG_FILES([src/lisp/core.lisp])
AXIOM_MAKEFILE([src/boot/Makefile])
AXIOM_MAKEFILE([src/interp/Makefile])
AXIOM_MAKEFILE([src/share/Makefile])